1

Upgrading one of the site collections from SP2010 to SP2013 failed with the error below:

Unsupported Language Pack References

The following language packs are referenced from content in this site collection, but are not installed on this farm: Arabic (Saudi Arabia) (1025) Please wait for the appropriate language pack to be installed and then try this operation again.

How can I remove this reference from this site collection?

  • Do you installed the Arabic language pack in your destination farm? – Mohamed El-Qassas MVP Jun 18 '17 at 20:13
  • Instead of finding and removing the language pack references, you should go on and install the language pack on your SP2013 server. Also usually SharePoint gives the instructions of what should be done when checking the upgrade's health check (see Point 3 in this article) – moe Jun 18 '17 at 20:23
0

Unsupported Language Pack References occurred in case the sites in site collections are using a language pack that already not installed on your SharePoint 2013 Destination Farm.

So the recommended solution is:

  • Installing Arabic Language pack for SharePoint 2013 on your SharePoint 2013 Festination Farm.
  • Then Run Test-SPSite http://sitecollction -Rule 99c946f7-5751-417c-89d3-b9c8bb2d1f66 to make sure that the issue has been solved.
  • We are upgrading the farm from SP2010 to SP2016 so upgrading to SP13 is just a step to upgrade to SP2016, we have around 200+ site collections to be upgraded and only two of them showing this error and I don't want to install a language pack that I don't need and may affect the migration to SP2016 so if there's a way to remove the reference would be better. – A Seyam Jun 19 '17 at 6:12
  • Language pack installed and same issue occur – A Seyam Jun 19 '17 at 8:00
0

I had 3 SP2013 servers used to migrate to SP2016 each has its own SQL and SharePoint farm, for some reason when I get this error on one of the farms it refused to upgrade even after I installed the language pack but when I mount the database on a different server and started the upgrade it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.