I am stuck to a problem in SharePoint. When I click on Edit item and View item in a SharePoint list, its showing a blank page. How should I resolve it? I have attached the same link here:

  • Is there any web parts are placed on that pages..? – TARUN Jun 16 '17 at 6:15
  • This generally happens when we add some java scripts in view/edit page and there is error in script of you forgot to close script tag – Dhaval Kariya Jun 16 '17 at 6:34
  • Do you have defaults forms available into your list. If yes, then try to access https://url_to_list/NewForm.aspx or https://url_to_list/EditForm.aspx. If this is working fine, then there is some issue with customization on Active requests new.aspx form. @DhavalKariya suggestion is the first thing i'll look for. Just open developer tools on your browser and check for any console errors. – ThinkB4Code Jun 16 '17 at 7:13
  • pls mark my answer if I have solved your problem – DvG Jun 20 '17 at 12:11

This is very common issue when user closes out list web part on any of the list or library pages


  1. Open faulty page in web part maintenance mode to check is there any web part / script added to that page or not
  2. Once it’s confirmed go back to faulty page
  3. Click on Site Action > Edit Page
  4. Click on Add a Web Part option
  5. Then from the web part category list navigate to bottom most categories – Closed Web Part
  6. Select it and it will give you "untitled" (in most cases) in the right pane
  7. Select and click Add

Now what in case someone deleted the web part

  1. No worries open the same page in SharePoint Designer
  2. Click on Insert and from the data view category choose the option related to your page (New, Edit or Display)
  3. Add it to the respective page and that’s it.
| improve this answer | |

It has happened with me also. Here is my quick Fix

  1. Use Internet Explorer browser
  2. Remove the later part of your URL after .aspx? & then once page loads completely click on Edit Page option . viz.


PS: Please avoid sharing your complete SharePoint site URL over public forums. Always hide your account/tenant name

| improve this answer | |
  • It occurs usually when you are using script web part and it looses the context once you stop editing the page. I am sure this fix will work for you – DvG Jun 16 '17 at 6:44

Go in SharePoint Designer in the editifs page of your list. Remove the script editor webpart and save.

| improve this answer | |
  • 1
    Please could you expand on your answer? – SPDoctor Aug 15 '18 at 6:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.