3

Recently I configured SharePoint online on-premise server. I am trying to perform REST API to fetch lists from SharePoint. For that I need to authenticate into SharePoint server. But it throws "404 Not found" on form-based authentication. Before that I am able to authenticate into SharePoint trial version, but using the same source code online on-premise server fails to authenticate.

These are my authentication steps

  1. Get security token using POST: login.microsoftonline.com/rst2.srf

  2. Get access token using security token from previous request by using POST: mydomain.sharepoint.com/sites/dev/_forms/default.aspx?wa=wsignin1.0

  3. Get form digest value using access token from previous request: POST: mydomain.sharepoint.com/sites/dev/_api/contextInfo

The URL https://mydomain.sharepoint.com/sites/dev/_forms/default.aspx?wa=wsignin1.0 throws "404 Not found error". Why I am getting this error?

Is there any change should I need to support to get successful authentication into SharePoint online on-premise server?

For more details:

SharePoint trial account: mydomain.sharepoint.com

username:user@mydomain.onmicrosoft.com

password: password


SharePoint online on-premise account: mydomain.sharepoint.com/sites/dev

username: user@mydoamin.com

password: password

  • 1
    my apologies, what do you mean with "SharePoint online on-premise", do you mean SharePoint Hybrid Architectures? blogs.perficient.com/microsoft/2014/04/… – Marco Jun 14 '17 at 13:35
  • Its an online account but user is not in active directory, that is user name is ending with "onmicrosoft.com". – gkal Jun 15 '17 at 4:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.