I ran below command to set the Continuous Crawl Interval in SharePoint 2016:

$ssa = Get-SPEnterpriseSearchServiceApplication
$interval = "1"
$ssa.SetProperty("ContinuousCrawlInterval", [int]$interval)

But in Search service application, content source "Local SharePoint sites" does not showing any interval set. Even on Search Administration page no Recent crawl rate and no Searchable items shows and in Crawl Log page everything shows 0. Please guide.


You can try below powershell code:

$ssa = Get-SPEnterpriseSearchServiceApplication
$cs = Get-SPEnterpriseSearchCrawlContentSource -SearchApplication $ssa -Identity "Local SharePoint sites"
Set-SPEnterpriseSearchCrawlContentSource -Identity $cs -EnableContinuousCrawls $True

$ssa.SetProperty("ContinuousCrawlInterval", 1)

Reference- Enable continuous crawls with PowerShell

| improve this answer | |
  • hi @prakash, did you try the above code, is it working for you ? – Gautam Sheth Jun 14 '17 at 11:53
  • glad i could help, if it worked, could you please mark/accept it as an answer so that it doesn't show up in the unanswered section, its the checkmark below the upvote button ? – Gautam Sheth Jun 27 '17 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.