2

How come my Macros work when the Excel file is saved locally from SharePoint but if I just open the original file from SharePoint and check it out, my macros will not function?

If I have the file locally saved, everything runs smoothly but if I am just pulling the file directly from share point and try running the macros, I get a run time error: "run-time error '-2147467259 (80004005)' it is already opened exclusively by another user, or you need permission to view and write its data" Even after the file has been checked out.

Please let me know if you have any solutions. Thank you.

2
  • check if you open the file on the browser? Commented Jun 12, 2017 at 18:40
  • Hi @Walid Khori , welcome to SharePoint StackExchange :) , Could you please take a quick tour at sharepoint.stackexchange.com/tour to get informed badge! Thank you for your contribution! Commented Jun 12, 2017 at 19:58

1 Answer 1

2

With the reference to Differences-between-using-a-workbook-in-the-browser-and-in-Excel, you can't run Macros on SharePoint Excel online.

However, if you actually mean you have uploaded the .xlsm file to a document library then you should be able to open the file and provided you have responded to the prompts correctly then the macros should be enabled and function.

One of these is to enable content followed by do you want to make this a trusted document, once you've passed this the file will open without prompting.

So if you are experiencing issues you will need to check the settings under File, Options and Trust Center to see what may be causing the issue.

1
  • When I open the document on my computer (not online) after pulling it from sharepoint Excel asks me to "check out" the document. Now I have the document locally saved (.xlsm) extension. Now when I try running my macros I get the error message discussed earlier. It will not run correctly unless the document is physically saved on my computer. Any ideas on a solution to this issue? Thank you so much for your help!
    – user67838
    Commented Jun 13, 2017 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.