2

I have been struggling with this issue for a few days now, and can't, for the life of me, figure out what the problem is.

I have created a SharePoint 2013 workflow which fires when an item is added to the Document Requests list. This workflow is to assign a task to me to approve the Document Request. If I approve, it is to send an email to the creator of the Document Request to tell them that the request is approved; if not, it is to send an email stating that it's been rejected. Please see this link showing the workflow steps: ![workflow steps]https://ibb.co/n6wfqv

What I have been struggling to understand is why it is not sending out the email to the task creator, or at least appears not to. It has sent out this email during one initial test, but stopped since.

The workflow completes without issue, and there aren't any errors/anomalies appearing in the ULS logs. I have tried adding a pause after the sending of the email to the request creator, as I have noticed that there is a delay of ~3 minutes between the creation of the initial Document Request and the approver task email, but to no avail.

I have not set up the SMTP server feature on the SharePoint server as we are pointing to a separate mail server, and, according to my knowledge, would not need this feature.

I assume that the issue would be with SharePoint/Workflow Manager not being able to communicate with this mail server, because the approver task email would not be sent out as well - is this a safe assumption?

Would the issue lie with the workflow, or with the Mail Server/Outgoing email configuration settings in Central Admin?

If there is another thread that answers this question, please point me in its direction. I have looked around, but could not find anything with a similar issue (frustration/lack of experience might be clouding my thoughts as well.)

Thanks for all your help :)

  • Can you try to set alert on the document library - on any changes like new / edit and see if emails are getting triggered. If you receive alert notification then smtp settings are correct else need some debugging in that area. – Monica Jagani Jun 12 '17 at 9:38
  • Welcome to SharePoint StackExchange :) , Could you please take a quick tour at sharepoint.stackexchange.com/tour to get informed badge! Thank you for your contribution :) – Mohamed El-Qassas MVP Jun 12 '17 at 9:44
0

So I managed to figure out a solution to my problem, and the solution was right under my nose :)

Everything was indeed working as it should, hence my not seeing anything unusual. However, there's a folder in Outlook 2010 (my email client) called "Junk Email" and clever me had not thought to check it until I registered on SharePoint StackExchange today! This is where all the emails were going - Outlook must have incorrectly assumed they were spam/junk.

Thank you for the answers, Monica and M.Qassas. I'm new here and I apologise for posting this question incorrectly. How do I mark it as answered?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.