4

I'm trying to set up a Traffic List priority list on my SharePoint 2010 list. I'm following this Blog: https://blog.splibrarian.com/2012/06/06/using-calculated-columns-to-add-color-coding-to-your-sharepoint-lists/. I get to point 5 and in the Insert Column list I'm not getting 'Category'. I set up a Priority Indicator Field Traffic Light SharePoint List. So on the right of the screen grab is what I've done and on the left is from the Blog.

Nothing so showing up in the Priority Indicator column after I save it. What am I doing wrong?

2

I think the issue is that you are not using the correct reference marks " and correct apostrophes '.

If the formula is directly copy+pasted from the source, there might occur a formatting issue which changes the " marks to and ' marks to , which neither of are understood by SharePoint. Try to type the correct reference marks and apostrophes by hand to your formula.


Edit: based on the comments, also other suggestions have been given:

  • Use instead of •
  • Confirm that the list items have a selected Priority in the Priority-column
  • Cheers. tried that, I also copied and pasted it into NotePad and back again and it hasn't worked. – Dazza Jun 12 '17 at 8:55
  • @Dazza Copy+pasting it through e.g. Notepad doesn't change a thing, as the incorrect marks would not be reformatted. They need to be manually fixed. Also you could try to replace • by the direct ASCII-symbol: . – moe Jun 12 '17 at 9:09
  • Also just a simple check: as you mention "nothing showing up", have you actually defined priorities for your list items in the Priority column? Are they using values such as 1 or 2? – moe Jun 12 '17 at 9:12
  • After I pasted the formula in from Notepad I put the punctuation in manually. I created the Priority column as a Choice menu but no I haven't set up any defined priorities. I'll take a look at how to do that. – Dazza Jun 12 '17 at 9:47
  • Should the Priority Column actually be a Column type in SP? – Dazza Jun 12 '17 at 9:56
2

I tried this solution out in a tucked away area on the live environment and it worked, so I think there's a problem between our live and dev sits causing the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.