1

I am stumped, new farm with old topology.

  • WFE1 (Web Services / Distributed Cache)
  • WFE2 (Web services / Distributed Cache)
  • APPS1 (UPS/CA/SEARCH)
  • SQL
  • WAK1 (no provisioned but for future)

All over SSL through a load balancer. Basic Web Applications (Portal and MySites). Provisioned with AutoSPInstaller.

Everything ran well, initially I had an issue with Search Topology having certain items on the WFE, I reprovisioned search with everything on the APP server.

Issue I am having now is Search is returning error: Search has encountered a problem that prevents results from being returned.

ULS Logs show quite a few errors but two that strike interest are:

User Profile Application Proxy failed to retrieve partitions from User Profile Application: Microsoft.Office.Server.UserProfiles.UserProfileApplicationNotAvailableException: UserProfileApplicationNotAvailableException_Logging :: UserProfileApplicationProxy.ApplicationProperties ProfilePropertyCache does not have c2ca0b79-5666-4057-b087-26f96bd04964    
 at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_ApplicationProperties()    
 at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_PartitionIDs()    
 at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.IsAvailable    (SPServiceContext serviceContext)

This is interesting since I see it when I run into the MySite error (cannot load User Profiles). The next one is Search Specific.

w3wp.exe: All query processing components are in 'Failed' status.

Followed by:

A failure was reported when trying to invoke a service application: EndpointFailure Process Name: w3wp Process ID: 4344 AppDomain Name: /LM/W3SVC/1444782454/ROOT-1-131413968049090860 AppDomain ID: 2 Service Application Uri: urn:schemas-microsoft-com:sharepoint:service:ce139799fb784704ab3fed22ca098351#authority=urn:uuid:7f4f14eea35b45de8d8fe8c8ae5273c9&authority=https://sp13-app1:32844/Topology/topology.svc Active Endpoints: 2 Failed Endpoints:1 Affected Endpoint: http://sp13-app1:32843/ce139799fb784704ab3fed22ca098351/SearchService.svc

Things I have tried:

Sts3 protocol is sts3s as the whole farm is only available via SSL Checked permissions on UPS Application --> Farm/MySite/Portal/Services accounts all have full control. No search account does but I don't think that's required.

Recreated MySites web app and Search with both AutoSPInstaller and SharePoint CA with no luck.

IIS Resets/SP Timer Resets/ Stop&Started UPS/ Same with Search.

Everything else seems to be working just fine. I am ready to pry my eyes out.

2

From the error you reported, looks like 1st you have to fix the User Profile Service. I would try couple of things

  • Stop the UPA sync if you have that
  • Stop the UPA service from Central admin > System Settings > Managed Services on server. Stop UPA service here. repeat this on all the server where it is running.
  • Reset the IIS on all the servers. Make Sure no App pool for UPA is listed.
  • Now start the UPA services and Sync. test now.

If above not work, i would delete the UPA, make sure no orphan app pool in the IIS related to UPA. recreate UPA from Central admin not via AutoSpinstaller (I never had a luck with it).

For the search service, i am seeing two end point while 1 active and other failed. But you said, you have Search only on one server. Make sure Search stoped on the server which are not part of it.

I would also clear the Config cache on the server.

  • Thanks! I will follow those instructions. UPA is up and running on the APP1 server, sync works and no errors but I will still follow your advice since that was my hunch too. The search topology used to be across all three servers so I am wondering if there is something orphaned there. – Robbeh Jun 12 '17 at 15:14
  • Ok I followed the advice. I made a mistake in trying to start UPAS on the WFE and it got stuck in starting. So I just went ahead to reprovision UPA. I tried via PS but it didn't work. So I tried via Central Admin and it looks good. It seems no more UPS errors but I still get the Query error above and A failure was reported when trying to invoke a service application: EndpointFailure Process Name: w3wp Process ID: 7816 – Robbeh Jun 23 '17 at 20:24
0

In addition to the above I made a bone head move that hopefully others will avoid.

With our farm setup I had UPS and UPSS running on APP1 but neither on the WFE. I realized you need to have User Profile Service running on the WFEs as well (not Sync though). When I started the service on those serves, the EndPoint error was gone and everything worked like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.