3

We are Migrated the VS solution form 2013 to 2016.

Sharepoint 2013 site searchbox are not displaying.

But in 2016 site all site pages searchbox are displaying. (only searchbox present in xsltlistviewwebpart)

I want to hide the serachbox from css or masterpage ? enter image description here i added listview webpart from site definition

Cannot import this Web Part. $Resources:eContractsCore,My_Tasks_ListWebpart False True True True

3

You can hide the search box by editing the webpart properties. Edit webpart--> Uncheck "Display Search box" (Under Miscellaneous)

enter image description here

If you are provisioning the webparts using modules into a page, you can edit the webpart xml and change property InplaceSearchEnabled from True to False like below:

   <property name="InplaceSearchEnabled" type="bool">False</property>
  • I am adding webpart from site definition.there i am using this InplaceSearchEnabled is false. But still the search box are displaying. – elina Jun 6 '17 at 12:00
  • i am using all site pages xsltlistviewwebpart. So in all pages in client site i can't do Edit webpart--> Uncheck "Display Search box" – elina Jun 6 '17 at 12:02
  • this works until i refresh and then the box shows up again and the box is once again checked. – user84385 May 16 at 23:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.