3

I am on SharePoint 2013.

A web application's URL is set as http://a.com in both web app and site collection. The default is set up as http://a.com. This site can only be accessed by https://b.com. AAM is set as https://b.com > Intranet(Zone) > https://b.com

The search was set to crawl http://a.com and as a.com was not accessible it was failing. So now when I changed to https://b.com, the crawl completed successfully but when I search, with query as (path:https://b.com), it does not show any result. I did quick mode and set as this site collection, it does not show any result. If I search with complete environment, I do get results from the site.

How do I fix the search path so that i can enable search this site only. Also the search on list and library is not working if I search from find an item box on List.

1

Search must crawl the default zone with Windows Auth enabled. The zone can have different permissions if desired. (Not being able to use the search box on a library or list is a dead giveaway as SharePoint cannot determine the correct "path").

I'm assuming that both a.com and b.com are serving the same site collection (a.com in the default zone and b.com in the Intranet zone via AAM).

In this configuration, configure search to crawl a.com with Windows Auth (this is the only configuration that will work). When the content is crawled, then search will function correctly for b.com and in-line search functionality should be restored.

Edit: for a detailed explanation, see this MS blog post: https://blogs.msdn.microsoft.com/sharepoint_strategery/2014/07/08/problems-crawling-the-non-default-zone-explained/

  • Hi Greg, Thank you for the update. That is what I was guessing but the issue now I have is the system cannot find a.com as this name is not used anywhere. Both a.com and b.com is same web app but as a.com is not resolved and App server cannot reach it, it cannot crawl a.com at all. So I think I need to enable a.com on the load balance as well and then crawl on a.com. Will adding IP on the Hosts file of the app server help. – Thisisme.. Jun 4 '17 at 16:19
  • How did you remove a.com from SharePoint? – Greg W Jun 4 '17 at 21:30
  • I did not remove it from SharePoint. I just replaced the crawl content from a.com to b.com. After that the crawl (full crawl) ran fine but the search is not displaying the result. – Thisisme.. Jun 4 '17 at 21:39
  • As documented in the link I posted earlier, search must crawl the default zone. In your case, the crawler must crawl a.com not b.com. Did you ever extend the web application in SharePoint? – Greg W Jun 4 '17 at 22:59
  • I am not sure. I did not change anything on the web application. – Thisisme.. Jun 5 '17 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.