2

I am creating an InfoPath form in InfoPath Designer 2013. I have added a multiple-selection list box to the form, which gathers data from a SharePoint list. I have also enabled the "Allow users to enter custom values" checkbox, so users can enter their own text, if required.

However, when running the form, the checkbox for the custom text is already ticked by default. How can I change this, so that none of the check boxes are ticked by default?

Solutions such as the one detailed here (https://social.msdn.microsoft.com/Forums/en-US/721c14fa-3fe5-4a97-9d95-95290851b418/multi-choice-fill-in-type-field-do-not-want-a-default-value?forum=sharepointcustomizationprevious) show that it was at least possible in InfoPath Designer 2010, but it seems slightly different in 2013.

3

This behavior is very frustrating, but there is a solution. They just bury it pretty deep in the settings.

  1. In InfoPath Designer 2010, click on File->Form Options (from the middle column).
  2. Then from the "Category" list box, select "Advanced".
  3. Then click the "Edit Default Values..." button.
  4. Expand "dataFields" down until you find your checkbox field.
  5. Then uncheck the box next to the field.
  6. "OK" your way back out.
  7. Save and republish your form.

OR try the below,

You can use an action rule to set any value to any field in the form. Check for the tab DATA -> Form Load and play with the rules there.

Refrence: how-to-change-multi-select-to-be-blank-value-by-default-in-infopath-2010

0

Select the "Data" tab on your top menu, then select the "Default Values" icon. That will bring you into the menu where you can navigate to your field and deselect the field "Value" (so that there is no longer a check in the box).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.