3

I'm trying to troubleshoot why App Fabric Caching Service is DOWN on SharePoint 2013. I'm new to the installation so unsure of history.

The following line gives an ONLINE status

Get-SPServiceInstance | ? {($_.service.tostring()) -eq "SPDistributedCacheService Name=AppFabricCachingService"} | select Server, Status

Then tried

Use-CacheCluster
Get-CacheHost

and get :

xx.domain.x.x.x AppFabricCachingService DOWN

Windows Services show AppFabric Caching Service as not Running and set on Automatic. Tried manually starting but stops, is this normal behaviour?

Thanks

UPDATE on actions performed:

    PS C:\Windows\system32> $instanceName =”SPDistributedCacheService Name=AppFabricCachingService” 
$serviceInstance = Get-SPServiceInstance | ? {($_.service.tostring()) -eq $instanceName -and ($_.server.name) -eq $env:computername}

If($serviceInstance -ne $null){ $serviceInstance.Delete()}

PS C:\Windows\system32> Get-SPServiceInstance | ? {($_.service.tostring()) -eq "SPDistributedCacheService Name=AppFabricCachingService"} | select Server, Status


PS C:\Windows\system32> Use-CacheCluster
Get-CacheHost

HostName : CachePort                          Service Name            Service Status Version Info
--------------------                          ------------            -------------- ------------
xxx.xxx.xxx.xxx.uk:22233 AppFabricCachingService DOWN           3 [3,3][1,3]


PS C:\Windows\system32> 

enter image description here

ERROR In Events log Faulting application name: DistributedCacheService.exe, version: 1.0.4632.0, time stamp: 0x4eafeccf Faulting module name: KERNELBASE.dll, version: 6.3.9600.18340, time stamp: 0x57366075 Exception code: 0xe0434352 Fault offset: 0x0000000000008a5c Faulting process id: 0x1b44 Faulting application start time: 0x01d2da401b0fad47 Faulting application path: c:\Program Files\AppFabric 1.1 for Windows Server\DistributedCacheService.exe Faulting module path: C:\Windows\system32\KERNELBASE.dll Report Id: 5c8b5bac-4633-11e7-8160-005056850f1f Faulting package full name: Faulting package-relative application ID:

4

It is not normal, you have to fix the your cluster.

1st run this script to cleare all the running instances of the DC

$instanceName =”SPDistributedCacheService Name=AppFabricCachingService” 
$serviceInstance = Get-SPServiceInstance | ? {($_.service.tostring()) -eq $instanceName -and ($_.server.name) -eq $env:computername}

If($seriveInstance -ne $null){ $serviceInstance.Delete()}

Now run this command and it should not show any thing

Get-SPServiceInstance | ? {($_.service.tostring()) -eq "SPDistributedCacheService Name=AppFabricCachingService"} | select Server, Status

Finally Run the

Add-SPDistributedCacheServiceInstance

Wait for minutes now check the status again.

Use-CacheCluster
Get-CacheHost
  • Tried above and when execute 'Get-SPServiceInstance.....' the status is DISABLED and 'Get-CacheHost' shows as DOWN – Raj Chahal May 31 '17 at 20:44
  • after running the deleted script(1st), what is the stauts – Waqas Sarwar MVP May 31 '17 at 20:47
  • After delete script, the second script displays nothing, but the 4th script shows DOWN – Raj Chahal May 31 '17 at 20:53
  • did you run the add-spdistributedcacheservice....? – Waqas Sarwar MVP May 31 '17 at 20:56
  • I executed your suggestion in order, so after the deletion I checked with the second script and nothing was being reported, then ran add-spdistributedcacheservice.... and finally the 4th script. – Raj Chahal May 31 '17 at 21:03
0

The Distributed Cache service is not running from Services, so to start the Distributed Cache service you should use SharePoint 2013 Management Shell as following command:

$instanceName ="SPDistributedCacheService Name=AppFabricCachingService" 
$serviceInstance = Get-SPServiceInstance | ? {($_.service.tostring()) -eq $instanceName -and ($_.server.name) -eq $env:computername} 
$serviceInstance.Provision()

Then run the below cmdlet and check the status

Get-SPServiceInstance | ? {($_.service.tostring()) -eq "SPDistributedCacheService Name=AppFabricCachingService"} | select Server, Status

If the status still down. try to follow the steps mentioned by @Waqas.

Also, check Manage the Distributed Cache service in SharePoint Server 2013

  • Did not work for me, since the instance returned by Get-SPServiceInstance was null. – Emaborsa Mar 13 '18 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.