1

Essentially what I'm trying to achieve is to have a page with two Content Search Web Parts that each pull back items of a specific content type. To do this I have created a few custom content types on my site, however I only seem to be able to query/refine by one of content types and not by the other.

I can't think of anything I may have done differently when setting up the content types (they both have the same parent, same group and almost identical columns).

Can anyone weigh in on where I may be going wrong?

Edit: Using SharePoint Online

Thanks

  • Is it possible you haven't run a full crawl after the non-queryable content type has been created? – moe May 31 '17 at 15:30
  • I've kicked off a new one by going to Site Settings -> Search and Offline Availability and hitting "Reindex site". I made this content type last week so I would have thought that SP would have picked it by now... – dev_jd May 31 '17 at 15:38
  • Can you post the query test you are using? – Kevin Stone May 31 '17 at 16:11
  • Just using a basic query with a SPContentType refiner Expecting to see more than the single content type there. – dev_jd May 31 '17 at 16:41
  • Try switching to the Advanced mode in the Basic tab of the query editor dialog. For the query use ContentType:"Content Type Name Here". You could also assign the crawled property ows_ContentType to a managed property RefinableString** and re-use it for other scenarios – Kevin Stone May 31 '17 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.