11

Is there an easy way for a user to choose modern page as a home page on a team site?

More info:

  • I've created a modern team site (O365 group) and was able to choose a classic wiki page as a home page using a button in the ribbon. But there is no such button on modern pages. That sounds like a huge drawback.

While writing the question, I've realized we can use this method:

  • Activate Reporting feature (site collection)
  • Activate SharePoint Server Publishing Infrastructure Feature (site collection)
  • Activate SharePoint Server Publishing feature (site level)
  • "Welcome page" will appear in site settings. Use it to choose any URL for a home page.

I guess, we can also do it via CSOM:

var ctx = web.Context;
var rootFolder = web.RootFolder; 
rootFolder.WelcomePage = "/SitePages/newHome.aspx";
rootFolder.Update();
ctx.ExecuteQuery();

But is there any other easy way for common users to do it themselves? Something like a button in the ribbon would would be great. Am I missing something?

3 Answers 3

12

You can set a modern page as the home page. Go to the pages library. Select the desired page, on the top click ... you will see 'Make homepage' button.

enter image description hereenter image description here

Other way is right click on file for options and select the "Make homepage" option. enter image description here

5
  • 2
    Just additional input you can also do this by clicking ... right next to the file name. May 31, 2017 at 16:20
  • Great Explanation @S Merchant! We really appreciate this type of answers :) Please Keep up :) May 31, 2017 at 17:18
  • @VenkatKonjeti Thanks for fixing. I was about to edit this. :) May 31, 2017 at 20:49
  • @SMerchant, thank you. I didn't guess to try to find in in the modern page view. Classic view didn't have this option at all. Great to know there is an easy fix for this task Jun 1, 2017 at 3:18
  • Thanks! Also, make sure to have the new desired page "Published" otherwise the "Make homepage" option won't appear.
    – Jess W
    May 16, 2019 at 5:01
3

Make sure that your Site Pages library is using the New experience. You can enable it in Library settings > Advance settings > List experience.

1

Note that if you create a new Site Page, make sure to Check In the page before you will see the "Set as Home Page" link show up in the modern ribbon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.