3

I have a Team Site collection which has the Publishing features enabled. When I click on the Site Settings icon and select "Add a Page" it always wants to create a site page under the "Site Pages" library. How can I change this default to a wiki page under the "Pages" library?

I've already limited the Page Layout and New Page Default Settings under the Site Settings / Page Layout and Site Template Settings but it doesn't seem to have effect.

3

To get this working you need to go to

Site settings >> Manage site features - Find Site Pages feature, Deactivate it (Don't worry this won't delete your site pages library)

now try clicking "Add a Page"

Add a Page

To get a wiki as default change default content type of your Document library to Wiki

  • Thanks, I don't see a Site Pages feature under either the Manage Site Features or the Site Collection Features. Do you know if it's part of another feature? – gsr51 May 31 '17 at 19:14
  • I searched and found that "Site Pages" are part of the "Wiki Page Home Page" feature. I disabled it and it seems to do the trick. Thanks! – gsr51 May 31 '17 at 19:18
  • i know this is 2 years old, but I have been searching for this exact answer for DAYS! took so many different ways of constructing a google search to find this answer. TYVM – Bob Nocraz Mar 26 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.