2

Power BI is added in a share point online site using script editor. It is working well on Chrome but not appearing when browsed in IE. I have IE11. The issue is with all the users. Can someone suggest what could be added in the script to make it IE compatible?????

  • I also (still) notice problems loading PowerBI iFrames into Sharepoint 2013 on premises, only in IE11. They fail to load about half the time. It works fine in Chrome, Firefox, and Edge. – Dave Sep 7 '18 at 19:26
0

Based on the Supported browsers for Power BI the Power BI is supported in these browsers:

  1. Microsoft Edge
  2. Internet Explorer 11
  3. Chrome desktop latest version
  4. Safari Mac latest version 5.Firefox desktop latest version

So try to do the following:

  • Add it to Compatibility View Settings.
  • Update your IE 11 to latest Update.
  • Try to use Edge and check if you face the same issue or not.
  • Try to browse this page outside your company and check if it's working or not. Maybe you are using a proxy in your company that causes this issue.

In case the above steps are not solved your issue, try to post your question at PowerBI forum

  • there is one thing quite strange , that webpart appears in our test site on IE but for production site it is not, any comment on that? – sweta May 26 '17 at 5:41
  • The error that coming is - "This content cannot be displayed in IFrame. To help protect the security of information you enter into this website, the publisher of this content does not allow it to be displayed in a frame". – sweta May 26 '17 at 5:57
  • <iframe width="500" height="360" src="app.powerbi.com/…" frameborder="0" allowFullScreen="true"></iframe> – sweta May 26 '17 at 6:04
  • have checked with all teh internet options and out of box things, do i go to edit any js file or something – sweta May 26 '17 at 6:05
0

You can change the IE Document Mode to IE 11 or edge from IE Developer tools which will fix the issue.

This is happening because SharePoint by default renders page in IE 10 compatibility.

Below is the reference article to modify the page.

https://paultavares.wordpress.com/2015/01/20/how-to-render-a-sharepoint-page-in-ie-using-edge-mode-without-changing-the-master-page/

0

go to

Tools > Internet Options > Delete (browsing history) > Uncheck the "Preserve favorites ..." checkbox at the top

add to compatible view setting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.