1

I'm working on SP 2016 Enterprise on premises with the April release of Office Online Server.

That all works and documents open in the browser.

Now I want to exclude a single document library from that behavior. The document library has a custom content type and document template that uses smart parts - these don't work in Office Online Server.

I've

  1. set the document library setting 'Opening Documents in the Browser' setting to 'Open in client application' - no effect

  2. activated the site collection feature 'Open Documents in Client Application by Default' - no effect

The clients are Windows 7, IE 11 and Office 2010. Chrome exhibits the same behavior - documents always open in Online Server.

Any ideas?

0

To resolve this issue, activate the Open Documents in Client Applications by Default site collection feature in Site settings. To do this, follow these steps:

  1. Click the gear icon to open Settings, and then click Site settings.
  2. Click Site collection features. Note If the Site collection features option isn't present, you must first click Go to top level site settings.
  3. Locate the Open Documents in Client Applications by Default feature in the list, and then click Activate.
  • Thanks, but I stated in the question that I had done that already with no effect. – Trevor Barry Jun 7 '17 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.