2

I have this weird thing going on with my tenant. I have successfully executed this PowerShell command on other tenants to retrieve Site collection administrators for user one drive for business. However, one particular tenant, I cannot get any return when executing the same command.

working

Get-SPOUser -Site https://sitename-my.sharepoint.com/personal/testuser1_testuser1_onmicrosoft_com | where {$_.IsSiteAdmin}

not working

Get-SPOUser -Site https://myplace.mss.com/personal/testuser1_mss_com | where {$_.IsSiteAdmin}

Is it the way the URL is named for mysite????

  • Do you get any error? what error do you get, please add details? You can try this Get-SPOUser -Site yourtenant-my.sharepoint.com | where {$_.IsSiteAdmin} or | select * to see everything. – SharePointer May 21 '17 at 19:20
  • I ran Get-SPOUser -Site myplace.mss.com/personal/testuser1_mss_com | where {$_.IsSiteAdmin} – mgmjtech May 22 '17 at 5:20
  • I got nothing coming back. Same result as other command. It works fine if I run on another tenant. The only different is my one drive URL is myplace.mss.com/personal/testuser1_mss_com instead of yourtenantname-my.sharepoint.com/personal/testuser1_testuser1_onmicrosoft_com. That is the only different with the way the URL was registered for mysite/onedrive. – mgmjtech May 22 '17 at 5:26
  • This is the result that I got from another tenant Get-SPOUser -Site test99-my.sharepoint.com/personal/… com | where {$.IsSiteAdmin} Display Name Login Name Groups ------------ ---------- ------ Testuser 1 Testuser1@test99.onmicrosoft.com {} Testuser 2 Testuser1@test99.onmicrosoft.com {} – mgmjtech May 22 '17 at 5:42
  • Have you tried any other commands? – SharePointer May 22 '17 at 16:56
-1

You need to be a site admin yourself to have it show the property as TRUE.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.