1

enter image description hereWhen I click on an item in my Discussion List, it opens that topic beautifully in a page called Topic.aspx.

But if I do a search, then click on an item in the search results, I'm brought to the Flat view of that item, and it looks terrible - it's the Flat view but all fields are laid out horizontally.

In Topic.aspx, the item appears within the Discussion List Web Part, which says the current view is Default - assuming that's either Flat or Subject. But it looks great.

I have other sites set up where search results items do not go to Topic page, they appear in Flat, and they look fine.

I've turned Launch Forms in a Dialog off/on. I've modified and created new default views, played with View Style and Folders/Flat.

I've been flummoxed by this for a while; any insight/help will be hugely appreciated.

Thanks, Matthew

0

When you click a discussion item from e.g. search ,the discussion item's link is generated so that it uses the current default view of the list the discussion item belongs to. Therefore it appears that Topic.aspx is the default view in this Discussion list. You can change the default view to Flat.aspx in your Discussion list's list settings.

  • Flat.aspx is already the default view. If I open the discussion list and select any item, it looks just fine. But if I do a search, and click an item, it looks bad - like in the picture. – Matthew May 19 '17 at 15:00
  • @Matthew If you have changed the default view recently, you need to run a full crawl before the changes are applied. – moe May 19 '17 at 15:04
  • Thank you @moe, that is helpful. With SPO, I'm guessing that means I just click to reindex the site and the list, and it happens within 15 minutes or so? But this problem has persisted for weeks. – Matthew May 19 '17 at 15:24
  • @Matthew yep, that's SPO's case. Reindex only your list as instructed here: support.office.com/en-us/article/… – moe May 19 '17 at 17:13
  • Yes, that's what I've done, doesn't seem to have made a difference. – Matthew May 19 '17 at 22:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.