0

I am working in SP online. I just realized that for some lists/libraries the search box is not working at all.

enter image description here

enter image description here

Suggestions? Remarks?

Thanks

2
  • WHat happens when you click Include? Are your items nearly identical? May 19 '17 at 11:28
  • I'm also experiencing this. I've tried re-indexing the List and have had no luck.. anything on your end?
    – user69333
    Aug 28 '17 at 18:53
1

Try redindexing the list: List Settings -> Advanced settings -> Reindex List

If there are multiple lists on same site affected you might want to index whole site: Site Settings -> Search -> Search and Offline Availability

Do note that in SPO it takes some time before reindexing kicks in so it might take some hours or a day until reindexing has full effect.

3
  • 1
    New items added to the site should appear in the index in less than 15 minutes. May 19 '17 at 11:27
  • @MatthewMcDermott Are you suggesting that the small green icon will disappear before one should expect indexing of that List Item?
    – user69333
    Aug 28 '17 at 18:52
  • The green icon has nothing to do with it. If you have not changed any of the default settings for search new items should show up in search results in less than 15 minutes. Aug 28 '17 at 23:49
1

The problem got solved by itself after 1 day. It seems MS takes some time to re-index lists. So next time I'll be waiting before alarming!

1
  • wjervis, between 15 minutes and 24 hours there is a difference. It is important to know that it is not just a question to take a coffee but wait one whole day.
    – Marpio
    May 19 '17 at 12:31
0

I fixed this by going to Site Settings > Site and offline availability > changed "Indexing Site Content" from No to Yes, then triggered "Reindex site" from that page.

Then I went to List Settings > Advanced Settings > "Reindex site"

And ten minutes later, the list items were appearing in search results.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.