0

I'm using SharePoint 2007 and I have a really simple workflow that should work on new items in a calendar list:

1) If the author is "MYDOMAIN\user1" or "MYDOMAIN\user2" etc. THEN

2) Set field "Division" as "UserDivision" THEN

3) Pause for 1 minute THEN

4) Send an e-mail to a specified user assigned to the "UserDivision" (the user is "hard coded" in the if block)

Sometimes this workflow works fine, and sometimes it is started and completed (as I can see on the item workflows) but no "Division" field is set and no e-mail is sent. I also checked that is happening with the same user. I mean, sometimes "user1" is correctly assigned to his own division and sometimes not.

ps: this is a little screenshot from SharePoint Designer flow. It's in italian, so please apologize me. (Imposta = set, Invia = send, è uguale a = is equal to, Autore = author, Divisione = division)

screenshot

  • make sure the timer service is started on the all servers and the system time between them all is sync'd. – Mike May 16 '17 at 14:06
  • @Mike it seems already started imgur.com/a/rB5rC I have just one SharePoint front-end server and another server with the database. – Pepozzo May 16 '17 at 14:31
  • Does the AND condition apply to both users? – HarryB May 16 '17 at 16:27
  • @HarryB uhm I hope so. I mean, this condition translated in code should be like ((author = "user1" OR author="user2) AND (otherCondition="Yes")). However if the AND condition is applied only to last user is not a big problem to me, because in this case an e-mail will always start and also I will always have a "Division" set. – Pepozzo May 18 '17 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.