When I am trying to edit a SharePoint 2010 site (clicking ribbon - Site Actions -> Edit Site in SharePoint Designer), it load SharePoint Designer 2010 application and gives me the following error:

"You do not have permission to open this Web site in SharePoint Designer"

This error I am getting on my Workstation (Win XP - IE8). I am logging on to my SP2010 site using the Administrator account.

Did anyone face this similar problem?

7 Answers 7


Check the SharePoint Designer settings in Central Administration as well as in your site. In 2010, the permissions for SharePoint Designer can be set to allow editing or not, as well as allowing specific types of actions using SharePoint Designer.

  • Yes, all 4 options are already enabled in the SharePoint Designer Settings, but I am still facing the same problem.
    – kamleshrao
    Commented Apr 3, 2010 at 8:53

My problem was probably caused by opening a different web application site, than another instance of SharePoint designer, and logging in with my test login account (different than my main account), or maybe it was because I was logging in to the web site multiple times, but one of them was with my test login account (with different credentials). The above fix that was suggested of logging to the site with a different user works, but is not a good fix, because I had to temporarily set my test login account to Site Collection administrator. Then I can change user to the correct user, and it will let me log in. But no matter what I do, whenever closing and restarting Sharepoint Designer 2010, its always trying to login to the test Login account now.

I don't know how to change Sharepoint designer to user my main account first!

--> Solved it! I noticed that when I run Internet Explorer, and hit the same URL / Site, that my login was showing up with my test user! So to fix, I logged on as my correct user and clicked on true for "Remember my credentials", and typed in my password. Then I did "Sign off" from site (not sure if this step was important or not. Then Exited Internet Explorer. Then re-launched Internet Explorer, and ran my site/url - now its showing my correct user! Exit Internet Explorer, and run SharePoint Designer 2010 - now when I open the same URL / site, its logging on with my correct user!

What's weird about this is that I tried this same sequence with SharePoint Designer 2010, but its not saving the default user changes, just works correctly when done from Internet Explorer!

Never login as a different user to a Sharepoint in Internet Explorer and while Sharepoint Designer 2010 is open! Something like this caused the problem!

  • 1
    Short answer: Closing IE and launching just SP Designer fixed this for me. No other steps required. Mind = Blown.
    – Goyuix
    Commented Oct 15, 2012 at 21:23

If you need to logon as a different user in SPD (Sharepoint Designer 2010) Click on the user icon on the bottom left and it will give an option.


Another cause to this which I found today was that the site was set as readonly via the stsadm -o setsitelock command.

To fix:

stsadm -o setsitelock –url http://<site title> -lock none

I had the same problem today. I couldn't connect to SharePoint 2010 using the SPD from the client or the server.

I tried everything. I set my user as the root user for every possible thing, like farm admin, site collection admin, site admin, etc.

The only thing that seems to have fixed is the setting the Anonymous Authentication to True in IIS directly in the Web Application. My actual settings are:

  • Windows Authentication: Enabled
  • Forms Authentication: Enabled
  • Digest Authetincation: Disabled
  • Basic Authentication: Enabled
  • ASP.NET Impersonation: Enabled
  • Anonymous Authentication: Enabled

To view these settings, go to: IIS -> Web Application Name (e.g. Sharepoint - 2308) -> Authentication.

Hope this helps.

  • HI Mario, I'm having the same issue and can't login to SPD when i have basisc auth set.I tried your settings but no luck. Just wandering did you have SSL set for your basic auth? Cheers
    – naijacoder
    Commented Oct 21, 2012 at 12:53
  • Hi naijacoder, I didn't have SSL set at that moment. After enabling all authentications the issue seemed to be fixed. Commented Oct 21, 2012 at 21:41

My findings:

  • When we use a client computer, the SharePoint 2010 designer uses the current Logged In credential to verify against the SP 2010 site.

  • I could not find any way for SPD 2010 to prompt for User Name / Password (something similar which happens when you use Browser to access the site)

  • To fix this issue, I added my Login (DOMAIN\Username) to the Home Owners group of the main SP 2010 site.

Hope this helps others.


Here are my findings:

  • check everything to make sure that your account has permissions for editing in the SPD
  • in the SPD, reopen any closed sites that you had opened before. Then click on the user icon at the bottom left to logout the current user.
  • retry to open the site to edit with your account.

Hope this help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.