I'm all of a sudden having several people having problems when opening up .doc files. All people have word installed but every time they try to open a .doc file from sharepoint it ask to search for a program to open this file with. One person it's actually trying to open as a pdf file.

Any solutions to this?

  • 1
    Mime types are screwed up.
    – Will
    Commented Oct 18, 2011 at 12:19
  • I'm assuming you are opening the documents from within SharePoint? Do .doc files open normally from your desktop?
    – Kit Menke
    Commented Oct 19, 2011 at 13:30

2 Answers 2


It sounds like a client side issue where the file type association has been changed, you may want to check to see what has been installed on the affected systems recently.


You might want to ask your client to perform the following steps on their IE:

  1. Click "Tools" from the menu within Internet Explorer.
  2. Click on "Internet Options."
  3. Click on the tab titled "Programs" at the top of the window. Another window will open. This is the Control Panel section entitled "Choose the programs that Windows uses by default."
  4. Click the link "Associate a file type or protocol with a program."
  5. Click on the file extension you would like to edit. Click the "Choose Program" button in the top right corner of the window.
  6. Click on the desired program in the "Recommended Programs" section.

    If the desired program is not listed, click the arrow on the line "Other programs." Click on the desired program. You may also browse for a specific program by clicking the "Browse" button.

  7. Click "OK."
  8. Click "Close."
  9. Close the Control Panel window.
  10. Click "OK" in the Internet Options window.

Reference 1: http://www.ehow.com/how_6924444_edit-mime-types-ie.html

Reference 2: http://msdn.microsoft.com/en-us/library/ms775148%28v=vs.85%29.aspx

  • I've actually tried this with one of them and word is associated with .doc extensions.
    – Joey Green
    Commented Oct 19, 2011 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.