3

I have form library customized with InfoPath form. When I am creating new item a form is opened in default view and I can fill some InfoPath fields. That's OK.

The problem appears when I want to edit item by clicking on Name (link to edit item with edit menu) field - InfoPath form is opened in this same view (default view) in which new items are created. I want to open by default different view when I want to edit items. I am looking for options similar to these in custom lists, where configuring views depending on situation (new, edit, display) is very easy. And it's important for me to get access to this edit view by clicking item Name (link to edit item with edit menu) field.

Do you know how can I solve my problem?

3

To change the default view for Infopath form do the following:

  • Open your list.
  • Click on your Item name field to edit your item.
  • The InfoPath Edit form should be shown > now go to Edit Page.
  • Edit the InfoPath form Web Part as shown below.

enter image description here

  • At view section, select your default view.

enter image description here

Note: whatever which way you are using to edit your item you should be aware of you have 3 options to edit your item.

  1. By clicking item Name that linked to editing item with edit menu.
    • It requires an independent edit by following the above-mentioned steps to change its InfoPath default view.
  2. Select an item and from the above ribbon click on Edit Item.
  3. From the Linked menu click on eclipse ... and select Edit item.
    • The second and third options require again to follow the above-mentioned steps to change its InfoPath default view.

So you need to follow the above steps 2 times. one for the first option (click on field name) and one for the second and third option.

[Update]

Based on your image, you will need to set the default view via InfoPath as the following

  • Open your InfoPath form using InfoPath Designer.
  • At page design > select your view that you need to set it as default as shown below.

enter image description here

  • Click on properties and check set as a default view.

enter image description here

  • Publish & check the result :)
  • Thanks for answer. It is working and now I can set default view for Edit Properties in item. However, when I try to edit item in browser by clicking on Name field a form is still opening a wrong view. My goal is to set default view when item is edited by clicking a Name field. How can I achieve that? – tm_ May 12 '17 at 7:05
  • 1
    Glad to hear it's working, Please don't forget to Mark my answer it's the true sign beside my answer. regarding your second question it's normal behaviour , just click on item name the old one will be shown, so edit page and repeat the above steps again go back to click your item name it should be working with a new view, Note: any page show the old view repeat on it the above steps. don;t hesitate to inform me if you still face any issue – Mohamed El-Qassas MVP May 12 '17 at 10:36
  • M.Qassas - thanks for all your advices. I have access to SharePoint only on my work days and I didn't want to reply without trying your advices. I changed my approach and now I don't need to edit form in different view than in creating new one. However, I still want to know how to attain it. I clicked on item name, form in edit mode was opened but I don't know how to get access to Edit Page from this edit mode. This is my ribbon: i.imgur.com/Eh60hjp.jpg And sorry for didn't marking your answer as solving problem, I will do that immediately as main problem will be solved. – tm_ May 15 '17 at 5:59
  • no problem, you are welcome, please check my updated answer! – Mohamed El-Qassas MVP May 15 '17 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.