2

I have an account in Office 365/SharePoint Online and I am creating a new Site Collection with the Template Publishing Portal.

I want to be able to add all kinds of different subsite templates below the Publishing Portal so I go into the Page Layout and Site Template Settings of the Site Collection and try to add the templates for the subsites.

enter image description here

Whenever I am trying to save the changes I keep getting error message: enter image description here

What is the proper permission to do this change?

1

This depends on the permission levels settings. Default it would be Full Control, I guess, but you could make your own custom group and apply this level permission to it (that is, if you have the permission to do this).

  • Hello Murphy, thanks for your reply. I thought so myself, but even if I give Full Control and also add the User to the Site Collection Administrators I get the same error. Could this be a bug with the Publishing Sites in SharePoint online? – gmakrygiannis May 12 '17 at 11:43
  • Don't think it's a bug, but you might want to check the Site Collection Features if all necessary is activated. I can't look it up right now, because I'm not a Site Admin at present. I suppose you have in Site Features, the SP Server Publishing activated, right? Also, go to Site Settings/Permissions/Permission Levels, select the correct group and check the Site Permissions Level maybe, just to be sure. – Murphy May 15 '17 at 15:25
  • I verified all the settings, everything is correct. I did a little experiment with another site collection domain.sharepoint.com/sites/publishing-site-col and it worked, so I created a service request for MS to attend to it. – gmakrygiannis May 17 '17 at 7:53
  • Sounds bizar. With site admin permission, I've always been able to access the site templates and add my own layouts, made in designer. Curious to know what's going on, I hope you will share it once "repaired". – Murphy May 17 '17 at 8:22
  • I created a service request through the Admin Console and we resolved it with MS yesterday. I will write the info in an answer. – gmakrygiannis May 18 '17 at 9:11
0

After support from Microsoft had a look, we found that the issue was caused by the fact that the Custom Script was not activated for the Site Collection. In case you are experiencing similar issue in the future, you can use the following steps to resolve it:

  • Open PowerShell as Admin
  • Type in Connect-SPOService "https://-admin.sharepoint.com" -credential "admin full email address"
  • Type in Set-SPOsite "SiteURL" -DenyAddAndCustomizePages 0

Additionally this may resolve any issues you might have with connecting via SharePoint Designer, as this has the same culprit. After changing the value for DenyAddAndCustomizePages both issues go away.

If you want to check the configuration value for any site collection you can use the following command, after connecting with Connect-SPOService as described above:

  • Get-SPOSite "SiteUrl" |fl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.