1

I am facing a strange issue wherein when I try to search for specific search terms in SharePoint 2013 enterprise search, we get an error as:

Display Error: The display template had an error. You can correct it by fixing the template or by changing the display template used in either the Web Part properties or Result Types.

Cannot read property 'value' of undefined (CoreRender: ~sitecollection/_catalogs/masterpage/Display Templates/Search/Item_Results.js)

This is happening only when we search for terms containing names of our Content Types. Other search terms are working well.

Did anyone too faced similar issues?

0

This is due to the display template(Item_Result.html) have any error. Possible reasons are any HTML tags mismatch, Adding symbols(<!--#_ ) to include Javascript is not closed properly, By retrieving managed property name which is not present.

  • The display template renders the results correctly for all other search terms. Only when I try to search for terms including the content source name, it throws an error. – Ashish May 12 '17 at 18:08
  • Please provide screenshot of what you have searched and provide some details what you have edited in display templates. My imagination is you retrieved the managed property in display template which is not properly get updated. Try by Updating result type property sync in site settings --> Result Types. Sorry, if my imagination is wrong – Kumaraguru May 13 '17 at 19:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.