1

when i try to delete a managed account through central admin

sorry, something went wrong the account is still being used by a application pool : name

I changed the application pool identity in iis to another account and no luck, i can't delete the account from managed account!

I tried to restart SPTimer, and IIS and restart server no luck :( I have tried removing the account from PS using the remove-spmanagedaccount ,i got : The account domain\user is still being used by these component

2

You have to make sure this account is not being used by sharepoint.For this

  • go to central admin > security > Configured the managed accounts
  • On this page, click Edit button infront of the service account you are trying to delete
  • next page, look bottom of the page and it will list all the apppool or services where this ID is being used.
  • Now you have to change id for that apppool / service from SharePoint not directly from IIS. then reset IIS and try again.
| improve this answer | |
  • yes i did , no luck , in farm components using this account show one app pool , I changed the application pool identity in iis to another account. and iis reset performed then restart server no luck, – Rany May 9 '17 at 20:11
  • 1
    did you change it from sharepoint not from IIS? cenral admin > security > configure the service account. from here select app pool and then change the id from last drop down. – Waqas Sarwar MVP May 9 '17 at 20:18
  • I'm sorry why this question on hold sharepoint.stackexchange.com/questions/214782/… could you help me ? – Rany May 9 '17 at 20:26
  • 1
    Honestly, i am not coding guru...But i always use Windows PwoerShell ISE. – Waqas Sarwar MVP May 9 '17 at 20:34
  • 1
    check this one marketplace.visualstudio.com/… – Waqas Sarwar MVP May 9 '17 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.