0

I have a button in a content editor that I only want certain users to be able to click. I am wondering if I give users either read or view only if they are able to click the button? I don't care if the button is visible to everyone, but it updates values that I want restricted to select users to update.

Alternatively, I have placed the button in a separate web part that I can hide entirely from users I don't want to click it but I am not sure how to set permissions/visibility at the web part level. I have read about "Audience Targeting" but I am not seeing that option when I edit my webpart.

Help with either solution would be greatly appreciated.

EDIT: Additional clarification, this is not a doc library or custom list. I am simply dealing with 2 content editors with HTML and JS in them. In the one area I display a counter, the other area I want to restrict allows for updating of this counter.

0

here's where you can find Audience Targeting, which is what I would use here:

  1. Edit the page
  2. Click the little arrow in the top-right corner of the web part and select Edit Web Part
  3. In the web part properties that you should now see on the right of the page, expand the Advanced block of options.
  4. At the bottom of this section is Target Audiences (see below). Here you can add the group of users who should see the button to grant them visibility.

Give this a try - hope it helps!

Target Audiences

  • 1
    As mentioned, I don't see the "Target Audiences" when in the edit web part properties. I have made a request to get it enabled in Central Admin which I believe is my issue. Thanks though. – mgrenier May 9 '17 at 19:56
0

I understand that you want to restrict the permissions to some users inserting/updating into a list when a user clicks a button on a form. As a best practice, you should break the permissions to the list and grant access to the required users. This approach will restrict insertion by going through the list and from a custom form as well. You can following steps.

  • Go to list settings
  • You will see a link "Permissions for this list"
  • You should break the permissions.
  • Remove current permissions.
  • Add new permissions to groups/users.

If you are looking for Audience target setting to the content editor web part. It will be under "Advanced" section of web part settings.

  • Thanks for you comment, it doesn't apply to my situation though. I added more details to my question. – mgrenier May 9 '17 at 15:47
  • Do you not see the target audience in the Misc section of web part properties. – Venkat Konjeti May 9 '17 at 16:22
  • You can also try adding restricted to a SharePoint group and verify the user is in SharePoint group then disable button. You can refer this link to check user in an SP group. sharepoint.stackexchange.com/questions/86912/… – Venkat Konjeti May 9 '17 at 16:23
  • 1
    You can use Target Audiences with the Content Editor webpart and show the webpart only to certain target audiences. If you don't see the target audience option. Here is the possible solution: stackoverflow.com/questions/14207773/… – SharePointer May 9 '17 at 17:48
  • @VenkatKonjeti no I don't see the "Target Audience" field which is my issue. I do not have access to my Sharepoint Server so I am trying to find a solution without it but if need be I will contact my IT dept to enable it and see if that resolves the issue, thanks. – mgrenier May 9 '17 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.