1

enter image description hereOur application team having below error while they are Deploying Feature through Visual Studio.

Error occured in deployment step Activate Features :Feature with id “X” is not installed in this farm ,and cannot be added to this scope

  • If you have any screen shot please provide – Suresh Bolineni May 9 '17 at 11:22
  • our application team is facing issue while they are deploying feature through visual studio can any one help on this would be appreciated – d babu May 9 '17 at 11:23
  • i already shared my screen shot for above error – d babu May 9 '17 at 11:23
  • Kindly attach screen shot with your question. If possible then try to change the scope of your SharePoint Solution according to your requirement. – Hardik May 9 '17 at 11:26
  • Already we tried this what they are we know at we application level to change scope they need for site collection level – d babu May 9 '17 at 11:31
2

I think you have multi server farm

*

Basically the error happens because VS 2010 do not support features activation on multi-server farms. However ,the devil is in the details, the exact explanation is in a previous step. It turns out that VS 2010 internally implements a call to the method SPSolution.DeployLocal http://msdn.microsoft.com/en-us/library/microsoft.sharepoint.administration.spsolution.deploylocal.aspx . That method is intended for troubleshooting purpouses of wsp files and as you can read on the MSDN documentation it performs a local deployment instead of an immediate deployment (Only to one sever of the farm) Therefore, the only solution to avoid the situation is to compile the code (build o re-build) , go to the VS 2010 top menu and select build -> package. After that a new wsp file will be created on the BIN folder of the project.

*

Ref1

Ref2

0

kindly go through the following URL which has complete solution for your problem

Server Error: Feature {GUID} is not installed in this farm and cannot be added to this scope

  • Thanku Hardik can you now see the screen shot now they want to deploy that feature sitecollection level is it possibel through Visualstudio – d babu May 9 '17 at 11:35
  • Use force in the feature properties to deploy the solution once. – Hardik May 9 '17 at 11:53
  • Hi Hardik the force feature i didn't find in properties can you help me how find this – d babu May 9 '17 at 12:17
  • First open the feature where you have defined the scope in your VS solution & press F4 to check its properties. There you will have attribute called Always Force Install so make it true from false. – Hardik May 9 '17 at 12:20
  • ok Hardik with this option any effect on code will take place ie:force – d babu May 9 '17 at 12:23
0

The second variant of problem is multiserver sharepoint farm (several webfrontend). In my case on dev.enviroment used 2WFE(sharepoint 2013), then deploy from VisualStudio impossble. Deploy project from PowerShell or SharepointInstaller. Debug - connect from VisualStudio.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.