6

I am trying to add an app to SharePoint and change the permissions it has. My problem is that I don't see the permissions after I have added them. Here is my work flow:

  1. Add the app using [...]/_layouts/15/appregnew.aspx
  2. Go to [...]/_layouts/15/appinv.aspx, look up the app, fill in the Permission Request XML box and click create.
  3. Go to [...]/_layouts/15/appinv.aspx again and look up the app.

After step three I would expect to see the Permission Request XML box being filled with the values I just entered, but it is empty.

Is this how it is supposed to be, or am I missing something?

The following snippet is what I enter in the permission box:

  <AppPermissionRequests>
    <AppPermissionRequest Scope="http://sharepoint/content/sitecollection/web" Right="FullControl"/>
  </AppPermissionRequests>
2

The Permission Request XML box is always empty, even when you have previously added permissions. Unfortunately it works this way, i was also wondering in the beginning. When you add permissions, they are assigned to the app, but are not shown later.

2
  • That is unfortunate. Do you have any documentation on this? I haven't been able to find any thing about this behaviour.
    – Mr_TC
    Oct 9 '17 at 6:21
  • I also didn't find any official documentation on this, but I have registered a few apps and it always works this way. The permissions are not shown, but the app can access the needed resources.
    – ilianiliev
    Oct 10 '17 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.