I am a SharePoint farm admin still I am unable to see the Manage services on server option with sharepoint 2013 CA?

Can anyone suggest what was the issue and I can see when I logged in with service account.

Thanks in advance!

  • Try not to browse starting from IE and navigating to the central administration URL, instead you need to hit Central Administration link (with the hammer and wrench icon) from Window Server. It has to do with advanced permissions. Also make sure you are logging on as a farm or install account.
    – Mike
    May 8, 2017 at 13:37

4 Answers 4


The issue is even though the admin or group is configured as a Farm administrator inside of SharePoint 2013 the admin/group is not configured on the server as an Administrator. The group must be added as a server Admin to be able to manage these functions. Add your user to Administrators group in your server & try again.


Open the Central Administration in the Browser as Runs as Administrator Try running IE (when you go to your CA) with elevated privileges, e.g. "run as administrator"


"run as administrator" was key for me, thanks


I had to physically login as the local administrator.

Whilst logged in as SP_Admin, an account designed to be a web application administrator:

  • Run as administrator did not display the link.
  • Run as different user "administrator" did not display the link.
  • Run as dedicated domain SP_Farm account could not view the settings.

SP_Admin and SP_Farm account is part of the local administrators group on the server.

NOTE: I think SharePoint was installed using the local administrator account.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.