1

My client's Project Server 2013 is using Project Server permission mode and I have also added "Everyone" in Root Site Visitors group but still some users get access denied unless I grant them access via Share option in PWA site and add them to Team Members for Project Web App. These users are Active users, they are part of Project Server' Team Members group but still I have to perform this extra step of adding them via Share option in PWA site.

As far my knowledge and experience, Share option in PWA site is applicable when we are using SharePoint permission mode but here my client is using Project Server permission mode. Is this is bug in Project Server build or is this a default functionality?

Anyone experience this similar behavior before? Thanks.

1

You should be aware of using Project Server permission mode differs from the default SharePoint mode in assigning the user to group and category rather than default SharePoint group.

I know it's complex than SharePoint mode meanwhile it's flexible to apply your security matrix requirements efficiently.

So to solve your issue you should add the user to the proper PWA group based on his permission by doing the following:

  • Open PWA instance > Open PWA settings > Below Security >

enter image description here

  • Make sure that the user is already added in Manage Users.
  • Go back to group section and select the proper group to add the current user.

Also, I advise to check the main differences between two permissions mode at my article SHAREPOINT PERMISSION MODE VS PROJECT SERVER PERMISSION MODE IN PROJECT SERVER 2013

  • Thanks Qassas, the above is already taken care. Users are part of Project Server Groups, they are in Team Members group but still I have to add them via Share option in PWA site. This is bit confusing, why this extra step if users are already granted access through Manage Users and then Manage Groups? – Zakir HC May 9 '17 at 6:30
  • sorry for the delayed reply @ZakirHC , regarding your confusion. you should be aware of the PWA instance is not require an extra step to add a user with share option and please try this with yourself as the following: open your PWA instance not the site collection that created when you create the web application , just make sure it's the PWA site collection then click on share to make sure that the user that you need to test is not listed, then go to PWA settings > Users settings add the user and assign its group as team member. go now to open PWA instance with this user it should have access – Mohamed El-Qassas MVP May 10 '17 at 19:46
  • Hi @ZakirHC are you tried this ? wait your feedback :) – Mohamed El-Qassas MVP May 11 '17 at 9:59
0

ZakirHC,

Since you are using Project Server Permission Mode all Permission added through SharePoint using Share option will be overwritten provided by Project Server Permission.

All Project Server Group have respective SharePoint Group with (Synchronized) written at the end. Those Groups are responsible for Syncing Project Server Permission with SharePoint so that user can access SharePoint Site.

As suggested by @M.Qassas you can Setup AD Sync with Project Server Group. In this way, you need to manage User from AD Group perspective. You can schedule AD Sync to run every day or you can run it manually. But make sure you don't have any disable user added into AD Group because this is known bug in Project.

If you have Disable users in AD Group and that Group is Synced with Project Server it will fail to Sync.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.