5

I create a page in pages not site pages in SharePoint 2013 and when I want to edit in advanced mode and insert data view it is gray out what should I do I check in and check out it several times but it does not change.

What should I do?

5

Try to do the following:

  • Check out your page.
  • Right click and Edit file in an advanced mode.
  • From the above ribbon > Click on code view tools > Click on Parse HTML.

enter image description here

  • Go back to insert tab > The Data view should be now enabled.

If the data view still disabled,

  • Make sure that you are trying to add data view in the correct place within Web Part Zone below <ZoneTemplate> then click on Parse HTML and The Data view should be now enabled.

If the data view still disabled,

  • So maybe The current site Master Page is Oslo Master Page. It looks like a bug in SharePoint designer 2013 where you can't add DataView to a page in a site has Oslo Master Page. and to overcome this issue,

    • You should temporarily change the master page from Oslo to Seattle.
    • Add your DataView in your page in SharePoint Designer.
    • Go back to change the Master Page again from Seattle to Oslo.

Check the detail steps at DATAVIEW IS DISABLED IN SHAREPOINT DESIGNER 2013

  • I tried but it doesnot work – behnoush samiei May 7 '17 at 12:44
  • what's the type of your page ? is it web part page ? – Mohamed El-Qassas MVP May 7 '17 at 13:13
  • I think I click on page On blue ribbon on top of the page and then click add – behnoush samiei May 8 '17 at 4:57
  • the above steps should be worked with both web part page and aspx page , please try again the steps :) – Mohamed El-Qassas MVP May 8 '17 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.