Using jsom I have created a custom file upload page to upload file to document library. But it is not uploading files with size more than 2mb.

How can we increase the size?

  • You can use the REST api which allows you to upload a maximum of 2GB. – Amit May 5 '17 at 11:03

In SharePoint 2013, the default file size limit set in Central Administration is for uploading single file manually in SharePoint libraries or using server side code. When you try to upload a file more than 1.5 MB , the following error was thrown

The request message is too large.

You can change the configuration if required from central administration refer link

And if you want to work with larger file than 1.5 MB then Rest is only the option.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.