I am unable to redeploy solution to my sharepoint 2010 site. When I try to retract solution, the task is registered in scheduled que but not executed (sharepoint timer and admin services are running, I tried to restart them and using execsvc commands)

<Deployments Count="1">
   <Deployment JobId="7f7fab8a-0b7a-4b00-b7f9-ccaf63e16a82">
      <Title>Wycofywanie rozwiązania uveventreceiver.wsp programu Microsoft Shar
ePoint Foundation</Title>
      <Schedule>2011-10-14 10:44</Schedule>
      <ServerType>Serwer frontonu sieci Web</ServerType>

PS. It is Sharepoint 2010 PL (Polish). I tried to install English language pack, changing in AdminContent, table AllWebs language and locale from 1045(PL) to 1033(EN-us).

Still problem is not resolved: I have got Polish Sharepoint SP1 (+CU June) installation with ENG language Pack, central admin is set to English (by database modification), timer jobs are not executed...

  • Wild guess: this problem may be related to the fact that the Central Administration site uses Polish language pack but the Type value (i.e. Retraction) is not translated. Oct 14, 2011 at 10:07
  • How to resolve that problem? I had installed SP1, Language Pack, Language Pack SP1 and CU June and after that timer jobs are not executing. SP2010 Administration and Timer are runnig, I tried to restart them.
    – marcinn
    Oct 16, 2011 at 20:03
  • My general advice is to use only original language versions of software (e.g. OS, SharePoint, SQL Server) in production environment - you always find more information searching for error message in English. Can you uninstall all SharePoint language packs and see if the CA site is reverted to English? Oct 17, 2011 at 7:05
  • The problem is that I must have Polsih version because all sharepoint UI should be in Polish. Now developers use english sharepoint version with language pack. So production is PL with language pack and developer env is EN with language pack. Is it possible to use in production env Sharepoint ENG and have all UI in PL?
    – marcinn
    Oct 17, 2011 at 8:47
  • Does the Central Administration site need the Polish UI? Oct 17, 2011 at 8:50

2 Answers 2


I think I faced this problem before. And for me the problem was a feature that contains an error and cannot be uninstalled. to come over this, before uninstalling the solution I have to deactivate then uninstall the feature using powershell with -force attribute. Once this is done, the solution uninstall correctly. Hope this solution help you


You should Deactivate your solution first. The correct steps are: 1. Deactivate features from the solution (if your wsp solution has any) 2. Retract solution (I propose to use stsadm -o retractsolution) from web applications (first run it with parameter -allcontenturls, second: with the -url parameter and give the Central Administration URL) If you want to completely remove the solution from a farm, also run stsadm -o deletesolution command.

Anyway you've written that you only want to upgrade solution, did you tried Upgrade-SPSolution in powershell?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.