3

After a reboot of one off the SharePoint servers I am managing, the webapplication seems broken. The root site collection gives the "Page can not be displayed' screen. Occasionally the site is working and presented in the browser. But after pressing CTRL+F5 the site loads for 15 ~30 second and then the "Page can not be displayed' screen appears. Also when closing the browser en reopening gives this behavior. Other webapplications on this server are still working. The site was working fine before reboot but after reboot I got this behavior.

In the system event log I see this message:

A process serving application pool 'SharePoint - 80' suffered a fatal communication error with the Windows Process Activation Service. The process id was '1320'. The data field contains the error number.

I am also getting a login screen several times even if the loged in user normally was logged in automatically

An update on the situation.

I have the problem on every server. The problem only seems to occur on the root site collection When I create a new webapplication and attach the contentdb same problem When I export the root site collection with Backup-SPSite and restore in a new contentdb same problem

I have run the DebugDiag tool but I see now errors. I tried attaching Visual Studio but The app pool stops during the problem and the debugger also stops

Another strange thing I noticed. The _layouts/settings.aspx does work in most occassions

I have another update on the problem. I tracked the problem to a piece of code that is using Linq to SharePoint to get some pages from a page library to show in a newsfeed control. There are about 1400 pages in that library. When I disable this piece of code the site works and I am not getting the login screen and sudden app pool restarts. The strange thing is that on my customers server this problem doesn't occur. On my server it does. The CPU and memory specs are the same. The only dif is that my customer is running Sp2013 SP1 with Oct 2013 CU. I am running SP2013 SP1 with Feb 2107 CU. Are there any changes in the Linq to SharePoint in this newer CU that can cause this issue?

Any ideas?

2

There are multiple reasons for this error. You have to check Event Logs to get more clue but if you could not get enough information then start collecting the dumps and analyze it. for starting point.

Check these links: https://technet.microsoft.com/en-us/library/cc735271(v=ws.10).aspx

and https://social.msdn.microsoft.com/Forums/en-US/2586b4ef-3be7-41e1-9d89-d2b469e567fd/a-process-serving-application-pool-appohsbe30-terminated-unexpectedly-error?forum=csf

  • Strange thing is, that I am experiencing this on all my servers. When I detach te content database and attach a new one and create a site collection everything works fine. – Danny May 4 '17 at 8:04
  • looks like something in that content database which is causing the app pool crashed, have u tried to check if their any orphan stuff in the db? – Waqas Sarwar MVP May 4 '17 at 14:32
  • How can I check that? In database status there is no message. It says no action required – Danny May 4 '17 at 14:44
  • I tried the powershell command $CDB = Get-SPContentDatabase $CDB.Repair($true) It gives <OrphanedObjects Count="0" /> – Danny May 4 '17 at 14:49
  • I think best bet is collect the dumps...looks like there is some issue with site collection ( might be a workflow, custom solution, branding), causing app pool crash....I am sure if you move the site into new content db then the issue with be same. – Waqas Sarwar MVP May 4 '17 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.