2

I have a report uploaded in SharePoint and it works fine. However i need to insert this report in Report Viewer inside Windows Forms. I get this error while using below code

"The permissions granted to the user "NT AUTORITY \ ANONYMOUS LOGON" are insufficient to perform this operation. (Rsaccessdenied)"

This is my code:

this.reportViewer1.ProcessingMode = Microsoft.Reporting.WinForms.ProcessingMode.Remote;
this.reportViewer1.ServerReport.ReportServerUrl = new Uri("http://web.corpname.ar/dev_report/_vti_bin/reportserver");
this.reportViewer1.ServerReport.ReportPath = "http://web.corpname.ar/dev_report/Documents/rpBalanceMasas.rdl";        
reportViewer1.ServerReport.ReportServerCredentials.NetworkCredentials = new NetworkCredential("ADMINCORP", "PASSCORPS", "RTM");
reportViewer1.Update();
this.reportViewer1.ServerReport.SetDataSourceCredentials(new[] {  new DataSourceCredentials () {
     Name = "dsConsultas",
     UserId = "RTM\ADMINCORP",
     Password = "PASSCORPS"
} });
this.reportViewer1.ServerReport.Refresh();
this.reportViewer1.RefreshReport();

Help me pls, Thanks.

  • What permissions your account "RTM\ADMINCORP" has on that specific report and on site level? – Muhammad Zeeshan Tahir May 26 '17 at 22:30
  • In ReportingServices is the administrator, and in Sharepoint is the farm administrator, but i'm trying with another accounts and get the same result. – Gabriel Jeremy Rodriguez River May 27 '17 at 13:27
  • Which account that is and what permissions it do have on the site? – Muhammad Zeeshan Tahir May 27 '17 at 13:29
  • Sorry but i understand what permissions, i only know the "RTM\ADMINCORP" is the admin in all sites (farm administrator), and in the Reporting services is the admin too(update, edit, design, delete, create, read, etc) and in the SQL Server is the sysadmind – Gabriel Jeremy Rodriguez River May 27 '17 at 13:41
  • What is suspect is, your credentials (RTM\ADMINCORP) are not passing to SharePoint and it tries to load the report Anonymously which fails and throws error. I am not sure if you need to do any kind of impersonation here. What i can suggest is, try running your desktop application by the same account (RTM\ADMINCORP) and see if it gives some results. Otherwise you may need to reconsider your code and try some different way. More details you add to your question, it will help to understand the situation. – Muhammad Zeeshan Tahir May 27 '17 at 23:49
0

Have you tried the following? Perhaps the following will resolve the problem

Go to SharePoint Central Administration. Open your Manage Web Applications in then click on your Web Application where problem exist, then choose the Authentication Providers. then uncheck the box of the “Enable anonymous access” then click Save

https://sharepointdevelopmentblog.wordpress.com/2016/02/15/report-bulider-3-0-nt-authorityanonymous-logon-error/

  • I can't do that, because in company protocols, the site should not accept anonymous connections. – Gabriel Jeremy Rodriguez River May 24 '17 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.