0

I have SharePoint 2013 Enterprise. If I open a Visio Document from a Doc Library it is immediately available to edit. If I open it from a List attachment ,it opens as Read Only. The only way to edit the document is to Check In and Check Out the document.

Please let me know how a document can be immediately available for edit when I open it from a list.

  • How you open it from list? are you mean it's attachment in list item when clicking on the attachment it opened as read-only? – Mohamed El-Qassas MVP May 6 '17 at 8:50
  • There is no check In /out option available on the list so the only problem I could think is if multiple people are editing this particular visio document. Do you get the same experience with all the documents? – SharePointer May 7 '17 at 11:21
  • Correct - its a list attachment. When I open this list attachment that opens on the Visio local to my desktop the document is READ ONLY. – daPlayaURH May 9 '17 at 3:20
  • Did you try downloading it from different browser? – SharePointMan May 9 '17 at 11:38
2

I believe the difference between the 2 options is because 2 different functions are called.

When you click a title in a document library, it calls for its onclick:

return DispEx(this,event,'TRUE','FALSE','FALSE','SharePoint.OpenDocuments.3','1','SharePoint.OpenDocuments','','','','1','0','0','0x7fffffffffffffff')

and you get the windows 'Open Document' prompt that allows you to choose Read Only or Edit.

When you click an attachment for a list item, it calls

DispDocItemExWithServerRedirect(this, event, 'FALSE', 'FALSE', 'FALSE', 'SharePoint.OpenDocuments.3', '0', ''); return false;

which opens the .vsd file as read only.

I wonder if you could add a customization to your form to replace the attachment onclick event with the one used by the view?

  • Could you point me to a link that may be helpful where I could achieve this hopefully thru some web part as I somehwhat limited to oob solutions and web parts (script maybe ?)... – daPlayaURH May 15 '17 at 2:12
1
+50

The setting you want is in Visio, not in SharePoint. Visio will, by default, open documents in Protected View from potentially unsafe locations (that includes SharePoint, but doesn't include local or network drives).

In Visio 2013, the option is in File > Options > Trust Center > Trust Center Settings > Protected View. You'll want to uncheck the box that says Enable Protected View for files located in potentially unsafe locations. Depending on your network setup, the setting might be Enable Protected View for files originating from the Internet.

  • I tried changing those settings and the document still displays as read only. I even tried to create a new Visio documnet, attached it to the list item and it still displays as READ Only..Any other ideas.. – daPlayaURH May 9 '17 at 3:19
  • Also I noticed if I open a Word document that is a list attachment it indicates "This document was opened from a server in read-only mode" It then gives me the option to Edit the document. – daPlayaURH May 9 '17 at 3:27
  • Kindly check this article....msoutlook.info/question/884 – Hardik May 9 '17 at 12:59
  • the msoutlook link does not open – daPlayaURH May 25 '17 at 3:42
0

I was able to get the file to open properly (not READ Only) by going to File > Options > Trust Center > Trust Center Settings > Trusted Locations. Then I selected the box for "Allow Trusted Locations on my network (not recommended)". I did try to add the specific Sharepoint path and it was not allowed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.