0

in SharePoint 2013 when I run full against a content source I get the following error in crawl logs and users are unable to search for the text exists in word documents that are saved in this site's document library.

The SharePoint item being crawled returned an error when requesting data from the web service. ( Error from SharePoint site: *** URL: https://xxx.xxx.xx:443 does not match any of the AAM Mappings registered for the server, CorrelationID: c4b0ed33-d646-a08a-32a3-79948b60590e; SearchID = 59A2334-7659-43fC1-9C63-72F7B5989590 )

I am facing issues again default zone URL I added in search service application content source begins with https://www.xxxx.com and some of the content crawled and some of the content did not crawl and returning above error plus with SSL certificate errors in crawl server. An operation failed because the following certificate has validation errors:

Subject Name: CN=www.xxx.com, O=xxxx, L=xxx, S=xx, C=xx Issuer Name: CN=Digixxx SHA2 Secure Server CA, O=DigiCert Inc, C=US Thumbprint: 1464F223EFC3F42xxx16C5CA3B6415591E4

Errors:

PartialChain: A certificate chain could not be built to a trusted root authority. RevocationStatusUnknown: The revocation function was unable to check revocation for the certificate. OfflineRevocation: The revocation function was unable to check revocation because the revocation server was offline.

1

SharePoint knows it's own URLs with a setting called "AlternateAccessMapping" (Basics here, advanced stuff here).

Your Search Content-Source should always contain the AlternateAccessMapping which is in the "Default" zone of your WebApplication. You might have a completely unknown URL there. It could get even worse: Your users use this unknown URL when browsing SharePoint! Then you should configure your AAM like described in both background-articles linked above.

  • Hi in the search service application content source i given the default zone url, but i have two urls in default zone – adilahmed May 3 '17 at 6:57
  • Could you please provide a screenshot of your AAM configuration? Please have a look at the "Public URL for Zone" column. There should be only one URL in the default zone. This should be used in the ContentSource. – MHeld May 3 '17 at 7:04
  • yes there is only one url in publiczone but different urls in internal url – adilahmed May 3 '17 at 7:11
  • You have configured a redirect if you have multiple URLs in "Internal URL" and one for "Public URL". Please use the "Public URL" in your ContentSource. sharepoint.stackexchange.com/a/209004/33662 – MHeld May 3 '17 at 7:16
  • hi redirect means i need to add in crawl servers host file , redirect internal ursl to WFE server IP? – adilahmed May 3 '17 at 9:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.