0

I'm hoping this is a fairly simple one. I've inherited a calendar with Calendar Overlays. A new calendar has been added 'ITSM' has been added, but the key color doesn't show when an item is added. It should be pink but is showing up as green. Screen grab attached.

enter image description here

  • in which column type you have set overlay?is it choice or single line of text? – Ekta Dobaria May 2 '17 at 10:31
  • It's a choice column – Dazza May 2 '17 at 10:44
  • I think your filter conditions in views are creating some mess.Please check it once! – Ekta Dobaria May 2 '17 at 11:20
  • Filter views seem fine – Dazza May 2 '17 at 11:31
  • Have you tried to create a new calendar to using the same calendar view for a new overlay? See if it is grabbing it differently or the same. Or just remove the overlay and reapply it. – Flat Banana May 2 '17 at 13:15
1

I checked it out on my end and everything works fine. Not sure what you're missing:

  1. Created a calendar & added events.

  2. Created a second calendar and added events.

  3. Created a view on the first calendar and then added the overlay of the second calendar.

  4. Copied the URL of the new calendar overlay view and added it to the left nav.

  5. Clicked the link and all colors in there and it works.

Check your link to see if it matches the link of the view you created. I suspect the link in your navigation is pointing to the default calendar and not the view.

  • Frustrating! I've spent all day on this and got no further. The other Calendar Overlay colours are working, and the Pink Overlay is showing up in the Calendars in the view key as pink, it's just on View itself that it's just showing as a default green. – Dazza May 2 '17 at 15:19
  • I don't think the pink view is set up right. I think the colour is just falling back to the default SharePoint colour, but I can't see what step has been missed – Dazza May 3 '17 at 13:00
0

Follow the blog given in the link

https://support.office.com/en-us/article/Overlay-a-SharePoint-calendar-with-a-calendar-from-Exchange-or-SharePoint-4caebe59-3994-4a94-9322-b31abb8a5e9a

  • Cheers but that doesn't help. That's all done. In the Calendar Overlay Settings the color is set to Pink #ffc8e8 but it's not showing that on the calendar when an event is added. It's SharePoint 2010 – Dazza May 2 '17 at 10:56
  • Ensure that Overlay calendar (Pink color one) is created under the master calendar rather than on the sub view/calendar. – SharePointer May 2 '17 at 11:10
  • Thanks, but that doesn't answer the question either. The Calendar Overlay doesn't fit in any of the caveats and seems to be set up correctly. – Dazza May 2 '17 at 11:13
  • The pink calendar does seem to be under the master calendar as it's showing up under the rest of the overlays – Dazza May 2 '17 at 11:16
0

Check and see it there is any embedded HTML to customize the color scheme. I followed the instructions on the article below and it voided any color changes I made to the calendar overlay.

https://davidlozzi.com/2012/06/20/customize-the-sharepoint-calendar-colors/

There are mutliple ways to do this, so if it's not embedded in an HTML web part the page may still have a custom color schema. this article shows explains an alternative way to do this:

https://www.spsimply.com/home/2018/6/2/sharepoint-customize-the-colors-for-calendar-overlays

  • add code samples to the answer, if the link will be deleted, there must be some sample for better understanding. – Zdeněk Vinduška Jan 24 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.