0

Is it possible to search within the Workflow History List?

<<site url>>/Lists/Workflow History/AllItems.aspx

I need to be able to search for a specific event, but I don't see a search field like regular lists.

I am using SharePoint online, and it doesn't display the "Find an item" search box.

1

I never use the Workflow History list for important events or auditable events related to my workflow, since the workflow history list is purged by the system. I create a second list that I write my audit log to. Then you have all of the "normal" list tools available to you.

  • How do you write it to another list? Some type of script? – cbbrown Apr 28 '17 at 13:38
  • 1
    In your workflow, just add a "Create List Item" activity and direct the output to your own custom list. We use a standard internal content type for all of our workflow lists so that they are searchable. Then we create a dashboard for the users with search. It is deployed to the Content Type Hub and available on all of our sites. You can also maintain the ID of the list item you created and have the workflow update the item to minimize the items in the list. It all depends on your requirements. No custom code, all OOB. – Matthew McDermott Apr 28 '17 at 22:43
  • Thanks for the suggestion. I have this setup and think it may work. I do have another question that this made me think of. Is there an action that will update all fields in a line item? or, do I have to create an action for each field that I need updated? – cbbrown May 3 '17 at 17:57
  • 1
    You should be able to add a single action for the item and then multiple field-value pairs. – Matthew McDermott May 4 '17 at 11:18
1

I'm on SP2013 on premise, and this worked for me to show the search box.

First, you have to set the list to be displayable by the browser. I did this through SharePoint Designer, unchecking the 'hide from browser'.

Then, I edited the 'All History' view page, and edited the actual web part for the view. In the miscellaneous section at the bottom, there's an option to 'Display search box'. Check that, save the webpart, save the page. This didn't 'stick' until I did the first step.

The list is shown to be searchable in list settings, but when I tested a search it never brought back any items. But maybe something else is going on timing wise, with it going from a hidden list to a viewable list...

  • Yes, I did the same thing, and it will not bring back any search results either. – cbbrown Apr 28 '17 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.