1

I am having some trouble with creating an email alert on a sharepoint posts library to send to our All Staff group. Our All Staff group is a Security group with the Universal scope (Synced from our AD) but when I create an alert using this group it does not send them updates. However it does send out an email notifying everyone that I have subscribed them to alerts for this library. Other groups I have tested work with no issues. I have deleted and re-added the alert as recommended by Microsoft.

  • You might need to check if these are blocked by exchange or any other spam filters. How many users are in this group? I would also suggest use MS Flow it is much better and give more flexibility to scale. – SharePointer Apr 26 '17 at 21:41
  • There are around 200 members, and I do not believe the messages are being blocked by exchange seeing as the original sign up message does come through successfully. I will check properly now though. – Dan Apr 26 '17 at 22:08
  • Couple of things to check...what permission group has on library? Also try to set alert on individual users from that group... see if individual received the updates email – Waqas Sarwar MVP Apr 26 '17 at 22:35
  • All members of the group have read access or higher, I have tried setting alerts for an individual which has worked too. – Dan Apr 26 '17 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.