3

In SharePoint 2016, When we share a document with other users, SharePoint send the sharing email to the users with the link of the item. In that email, from address is the user's own address ( which shared the document) and to address is end user's address.

But when we setup alerts in SharePoint, it send the email using the email address which we set in the outgoing email settings.

Now problem is, Alert email pass through our exchange relay but sharing emails blocked due to company policy.

Is there any workaround which force SharePoint to send the email always using the generic email address not user's own email address. Any powershell script or SMTP related configuration on SharePoint side only.

3

It can't be done. This behavior is hard coded. Your only option is to adjust the parameters of an Exchange Receive Connector (or what ever mail server you're using) to accept these emails, or create a new RC to accept these emails.

  • can Something in between exchnage and sharepoint...we can do...Like hold the emails on SMTP server then change the address send to exchange – Waqas Sarwar MVP Apr 26 '17 at 21:01
  • Don't quote me on it, but I don't believe that facility is available OOTB in Exchange (and I'm not aware of any 3rd party services). Microsoft's recommendations are to use an anonymous Receive Connector or set up an Externally Secured Receive Connector that only allows the SharePoint servers (via IP address) to relay mail to it. – Trevor Seward Apr 26 '17 at 21:02
  • I will not quote u but I am here to look options...MSFt recommendation did not get approval at our end...:( – Waqas Sarwar MVP Apr 26 '17 at 21:06
2

Finally this issue resolved in SharePoint 2016 Novemebr 2017 CU.

Some SharePoint features impersonate end users when sending email to personalize the message. For example, when a user requests access to a site, SharePoint will set the "From" address of the email notification as the user who made the request.

Some SMTP servers may block impersonation to protect users from unauthorized attempts to spoof their identities. If your SMTP server blocks impersonation, you can now configure each SharePoint web application to disable this behavior. This will ensure that SharePoint always uses the "From" address that is specified at the web application level.

Follow these steps to disable SharePoint email impersonation:

  1. Launch the SharePoint 2016 Management Shell.
  2. Run the following commands:

    $webapp = Get-SPWebApplication

    $webapp.OutboundMailOverrideEnvelopeSender = $true

    $webapp.Update()

Description of the security update for SharePoint Server 2016: November 14, 2017

You can read more about this: https://blogs.msdn.microsoft.com/joerg_sinemus/2017/11/15/sharepoint-2016-november-2017-cu/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.