3

I am working on sharepoint server 2013, and i have added an Enterprise wiki site collection and i enable the managed navigation + Friendly URL. now whenever i create a new enterprise wiki page a navigation term will be created automatically. so when i access my Site Setting>> site Navigation. i got the following:-

enter image description here

where i have navigation terms created under the "Site Navigation".

Now due to some issues where our designer made some bugs layout modifications, i wanted to restore my enterprise wiki site collection from a backup file which i took today.

so i run the following command to restore from a backup file:-

Restore-SPSite http://server_name/sites/site_name -Path C:\Backup\site_name.bak

Now the restore completed successfully. but when i access the site collection i got this error :-

Error loading navigation: The Managed Navigation term set is improperly attached to the site. (Correlation ID: 7ad0eb9d-fcc8-d003-e007-3d6c1a582fb6) 

and when i access my Site Settings >> Navigation , i can not find the Site Navigation terms. here is how the site navigation looks like:-

enter image description here

so please can any one advice , how i can re-connect my site collection with the old terms ?

  • what do the ULS logs say for that correlation? Anything juicy? Also, what user account are you using to run Restore-SPSite? – Mike May 2 '17 at 13:25
  • Agreed, ULS Logs, would be beneficial to help support the question. – Quinn Johns May 2 '17 at 19:28
0

It appears that the terms did not properly attach to the site, after the restore. Per (Source #1 and Source #2), the recommendation appears to be that with the Site Settings > Navigation, to select Structural Navigation for Global and Current Navigation, and save it, and set back to Managed Navigation. This appears to restore the relationship with the terms, respectively.

  • now changing the Navigation settings as you mentioned will remove the error.. but will not reattached the terms with the wiki pages... – john Gu May 4 '17 at 14:48
  • now i find this link which refer to the same problem... but when i try to run the command they mentioned i got the is exception Exception calling "AddSiteCollectionAccess" with "1" argument(s): "The current user has insufficient permissions to perform this operation." .. although i run the command using the farm account which have full permission on all the SP DBs including the managed metadata database.. so not sure what is the problem ? – john Gu May 4 '17 at 16:10
  • If you get an error “Export / Import failed due to insufficient rights”, you will have to open SQL Server Management Studio in the SQL Server machine and make sure that the service account used by managed metadata service application has bulkadmin rights in SQL Server. Give BulkAdmin rights to the managed metadata service account account as it is required for managed metadata service application import. Make sure to remove the bulkadmin permissions to the managed metadata service account as soon as you are done with the import/export process. – Quinn Johns May 15 '17 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.