I have a freshly installed SP2016 farm with WFM installed. I'm facing this weird situation where when we try to create a List workflow, we would have missing SharePoint 2010 Workflow and a warning message saying "The option for the SharePoint 2010 Workflow platform is not available because the server administrator has disabled that type of workflow."

My research shows most people usually have problem with missing 2013 workflow because they do not have WFM installed. And research also shows that 2010 Workflow comes with Sharepoint 2013/2016 by default, but I could not find any place to enable the 2010 workflow. I've been researching for the whole weekend without luck...i'm hoping someone can shine some light on this issue for me, much appreciated!

enter image description here

  • Anyone else having the issue? We have a SharePoint Server 2016 farm with this issue. SharePoint 2010 and 2013 Workflows blocked "because the server administrator has disabled that type of workflow". Is the same in all site collections. SharePoint Publishing Infrastructure is active and disabling/enabling does not change anything. Commented Dec 4, 2019 at 6:20

1 Answer 1


I think i found where the issue is. In the site collection features settings, the "SharePoint Server Publishing Infrastructure" was deactivated. Once I activated it, we can see the Workflow 2010 being available.

  • Well done solving your own problem. I did not actually ever encounter this problem before, and I was curious what the answer would be. Thanks for sharing.
    – Mihail
    Commented Apr 24, 2017 at 19:50
  • yeah, it was weird, this is my second time building the 2016 farm, first time I didn't have this problem. And I don't know how that particular setting relates to SharePoint 2010 Worflow.
    – David L.
    Commented Apr 24, 2017 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.