0

Open with Windows Explorer - Works for 3 web applications but does not work for 2 other web applications within same farm. This scenario tells me that it's not my computer since I can open for 3 different web application. I checked all the web app and "Browser File Handling" is set to "permissive". What else should I check?

Also "Client Integration" is checked for all 5 web applications. (Central Admin > Web application > Authentication Providers > click "Default" > Client Integration is set to "Yes")

1

Are the Web Applications under different (Trusted/Untrusted) URLs? For instance the working ones are an internal URL that is trusted whereas the one's failing to open are external, which fall under trust levels in the browser and the network? Differences in the network/browser configurations are very likely to cause issues with the open in explorer view.

Its an older article, however it has some good troubleshooting steps: https://blogs.technet.microsoft.com/manjesh/2010/01/03/all-about-explorer-view-in-sharepoint/ (links are in the referenced article, need moar reputation before posting them here)

Important points to be remembered when troubleshooting explorer view issues

  1. The Ports 137,138,139 and 445 should be opened between the client and the SharePoint server. We can verify it using telnet 137 and it should connect properly. the same can be done for ports 138,139 and 445
  2. If we trying to access an intranet site using FQDN, its good that we add the site to the Trusted Sites zone on client computers as a dot (.) in the URL will make IE consider that its Internet and accepts the security configuration for internet zone.
  3. Follow the KB article {removed} if the error is similar
  4. Apply if this is applicable {removed}
  5. If you restart the web client service on the client operating system , its always better to restart the O/S as there are some known issues reported. (operating system prior to longhorn)
  6. Apply this if suitable {removed}
  7. Avoid using Basic authentication . Basic authentication will work fine with WebDAV but has reported issues with FPRPC. If used , force web browser to use WebDAV 8.The account BUILTIN\NetworkService must have read and write access to “Temporary Internet Files folder” to successfully complete a drag-and-drop operation.
  8. Proxies configured in LAN also can cause issues in getting access to the explorer view
  9. Errors with lengthy URLS , follow this {removed}
0

Two things to consider:

  • If your WebApplication's URL contains a period (.), you should configure the AuthForwardServerList Registry-Key on your clients.
  • If your WebApplications use SSL, you might have enabled SNI in IIS. This can cause several issues (MS-Support Article, StackExchange discussion, background-article). SNI is mostly enabled because customers have a second certificate for their new WebApplications. If this is the case you cannot simply uncheck the box. You will either need a second IP-Address on your Server and bind your new WebApplications to it. Or you need one certificate which covers all URLs and assign it to all WebApplications. This article is a bit old, but shows your options very well. It has a lot of CMD-based configuration which can be done in GUI since Windows Server 2012 and IIS8.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.