2

I have created a regular Site Page which works fine in all browser except IE11. The content of that Site Page is not showing in IE11. After F12 and change Document Mode to IE=Edge Under Emulation all content are visible.

I make too much research onto this and find one solution i.e. adding meta tag, that works for me but that one is not a regular Site Page of SharePoint.

Please! add some suggestion that How I add <meta http-equiv="X-UA-Compatible" content="IE=Edge"/> to regular site page without disturbing master page?

I got no solution of this question till 12 days. Now, Whom should I reward bounty? Please! let me know, Thanks.

  • Not possible to my knowledge. You may have to look into the incompatibilities of why your content isn't rendering in IE11. Is it a webpart? Is it a custom page? Is it an ASP.NET embedded app? – Mike Apr 19 '17 at 17:35
  • In content editor web part, I am adding URL of a HTML5 page and SharePoint forces IE to use lower version i.e. IE10. – Utkarsh Dubey Apr 19 '17 at 17:42
  • As in an iFrame? – Mike Apr 19 '17 at 19:01
  • 1
    Sorry to say but now this bounty has been closed. Now you cannot assign bounty to any one, also it will not be refund to your account. See here – Trimantra Software Solution May 2 '17 at 9:08
  • 1
    No, If you are not satisfied with answer or any answer does not solved your problem then there is no meaning of accepting the answer. Because it will misguide to the future users and lead them to the wrong answer. – Trimantra Software Solution May 2 '17 at 9:19
1

Are you using a console.log() JS command? I ran into this once where In IE 11, the console is not defined until you bring up the console and refresh the page. It will cause JS errors and the page will not load correctly.

This below might help you if that is the case.

if( (window['console'] !== undefined) ){
    console.log( text );
}
1

Your master pages are probably default IIS and are either http-equiv="X-UA-Compatible" content="IE=8" or "IE=10"

If you must continue as-is then use an .aspx HTML file which loads with a meta tag that instructs IE to render in EDGE mode, and your XHTML page in an iframe. Your master page is probably already IE can only set the rendering engine once per page load. Once set it cannot be changed and thus all pages loaded through an iframe are forced to EDGE mode.

The rulesets are not easy to debug as it is affected by IIS .net patch version, web server settings, user modes, update of compatibility modes (both from Microsoft and via policy in your organization), IE Compatibility View Settings, HTML document type, ordering and precedence of any other HTML code, iframe or cross-site links, Browser security policy via Group Policy Object and Content Security Policy, CSS media queries, and any JavaScript routines that may affect those as shims or frameworks that make those assumptions.

I would try <!doctype html>, look to see what is no longer rendering, take a search at that over at http://caniuse.com/ or scan with Microsoft's tool to check for old depreciated tags over at https://developer.microsoft.com/en-us/microsoft-edge/tools/staticscan/

You may also enjoy - or start crying - reading What happens in Quirks Mode? - the choice is yours!

  • After adding script code in SharePoint:ScriptBlock and meta tag in <asp:Content ContentPlaceHolderId="PlaceHolderAdditionalPageHead" runat="server">. IFrame not visible in SharePoint site. Reference Github URL mention in answer. – Utkarsh Dubey Apr 25 '17 at 13:47
  • I want to make this work on SharePoint regular site page. Otherwise it works perfectly in simple ASPX page. Where I added HTML5 content. – Utkarsh Dubey Apr 25 '17 at 15:35
0

I was having same issue in my SharePoint Hosted App. I added below lines in my <head> tag.

<meta http-equiv="X-UA-Compatible" content="IE=edge, chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1.0"/>

I have found some interesting thing. I hope this help you.

Follow below steps.

  • Go to site setting
  • Go to Site Collection Administration
  • Go to Search Engine Optimization
  • Select Include these meta tags in pages

Here you are allowed to add <meta> tags for SEO purpose. And it will add tags to all pages while rendering. So Add your <meta> tag here.

Source

How I tested whether it will work or not?

  • I created simple Site Page. Checked the html source of the page by using "View Page Source" option of browser.
  • I searched for <meta> tag with name viewport. It was not found on the page.
  • Then I added <meta name="viewport" content="width=device-width, initial-scale=1.0"/> in SEO tag
  • Again I checked the source code and this tag was present on page.

Hopefully it should work. Let me know whether it solved your query

  • 1. I don't know the location of master page. – Utkarsh Dubey May 2 '17 at 9:35
  • 2. I don't want to disturb the settings of the master page. – Utkarsh Dubey May 2 '17 at 9:38
  • 1
    Got your point. Give me some time. I am trying at my end. – Trimantra Software Solution May 2 '17 at 9:39
  • 1
    Invalid custom meta value. This field may only contain valid meta XHtml elements. After adding meta tag at this place Search Engine Optimization. I got this error. – Utkarsh Dubey May 2 '17 at 11:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.