1

I've got a list that was created from an installed solution. The solution was created from our production and installed to this test installation. When creating or editing any form on this list I'm seeing errors. Editing or creating forms on other lists seems to work fine so I'm sure it's an issue with the form.

The first message is

SharePoint Designer cannot render XSLT in this Data View. Try to undo your changes or re-insert the Data View.

It's a brand new form, so I don't have anything I can undo.

The second message is

Failed setting processor stylesheet: 0x80004005 : Expected token ')' found 'NAME'. {ddwrt:DataBin('i',concat('ff14',$Pos),'Value','ValueChanged','ID',ddwrt:EscapeDelims(string(@ID)),'@AuthRec'-->d<--')}

That's a bit hard for me to read, but I DO know that where it's referencing @AuthRec, that's actually a column named "AuthRec'd". Is that the problem?

0

I don't really know what all it's saying, but it looks like I was right in assuming it was that column that was the problem.

I've deleted the column and the new form displays everything else perfectly fine.

I can only assume that a ' in the actual name of the column is the issue. I don't have any idea what the rest of the errors are telling me, but I know that they are gone when I removed the column.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.