1

We have a SharePoint 2016 environment setup which consists of following servers: 1. Wfe with distributed cache server 2. Application server 3. Search server 4. Database server

As part of installation we installed SharePoint 2016 prerequisites, then installed SharePoint 2016 binaries on all SharePoint servers, then ran SharePoint configuration wizard on all servers.

Now we need to create Service Applications as part of configuration, but none of the service application gets created successfully from UI or PowerShell. When we create Service Application from UI it takes long and then it give error: "Request timed out". When we look at created service application in central admin, we can see the service application name with status stopped, no proxy gets created for the service application, database and the application pool does get created.

When we create service application using PowerShell then it takes 3-4 hours but the command to create service application does not complete. Even deleting the service application take 2-3 hours from PowerShell, from UI it just times out.

There are no errors related to this found in ULS logs or Event logs.

Any ideas what could be the issue here, why service applications are not getting created?

Thanks in advances, Anna

Update - Following errors appeared in ULS Logs when i again tried to create managed metadata service application and word automation service application

(Watson Reporting Cancelled) System.Threading.ThreadAbortException: Thread was being aborted.
at Microsoft.SharePoint.Administration.SPTimerJobAsyncResult.WaitForCompletion(Object state)
at Microsoft.SharePoint.Administration.SPTimerJobAsyncResult.End()
at Microsoft.SharePoint.Administration.SPServiceApplication.ProvisionInstances()
at Microsoft.SharePoint.Administration.SPIisWebServiceApplication.Provision()
at Microsoft.Office.ConversionServices.Service.ConversionServiceApplication.Provision()
at Microsoft.Office.Word.Server.Service.WordServiceApplication.Provision()

Timer 'Word Automation Service': Canceling execution because App 'Word Automation Service' is not online (Status=Provisioning)

MetadataWebServiceApplication 'Managed Metadata Service' create failed. Exception: System.Threading.ThreadAbortException: Thread was being aborted.
at Microsoft.SharePoint.Administration.SPTimerJobAsyncResult.WaitForCompletion(Object state)
at Microsoft.SharePoint.Administration.SPTimerJobAsyncResult.End()
at Microsoft.SharePoint.Administration.SPServiceApplication.ProvisionInstances()
at Microsoft.SharePoint.Administration.SPIisWebServiceApplication.Provision()
at Microsoft.SharePoint.Taxonomy.MetadataWebServiceApplication.Provision()
at Microsoft.SharePoint.Taxonomy.MetadataWebServiceApplication.UpdateData(String sharedAppName, SPIisWebServiceApplicationPool applicationPool, Boolean unpublishAllPackages, String hubUri, Boolean doSetErrorReport, Boolean isErrorReportEnabled, Boolean doProvision)
at Microsoft.SharePoint.Taxonomy.MetadataWebServiceApplication.Create(String sharedAppName, String databaseName, String databaseServer, String sqlAuthUserName, String sqlAuthPassword, String failoverServer, SPIisWebServiceApplicationPool applicationPool, String hubUriString, Boolean isErrorReportEnabled, Boolean isInDefaultAssociation, Boolean isPartitioned, Int32 cacheCheckInterval, Int32 maxChannelCache, Boolean forceProxyCreation, Boolean fDeferUpgradeActions)

MetadataWebServiceApplication 'Managed Metadata Service' unprovision started.

  • I came across the error in one of the servers: Unable to create a Service Connection Point in the current Active Directory domain. Verify that the SharePoint container exists in the current domain and that you have rights to write to it. Looks like this is creating issue – Anna Jhaveri Apr 14 '17 at 12:27
0

Couple of things to try

  • If you have installed the Anti-Vrius on the servers, try to to disable it
  • check if firewall is causing this issue.
  • if you have any auditing or proctection software installed which may cause this issue.
  • Try to run the psconfig -cmd upgrade -inplace b2b force on the all servers and make sure all server report that no action required.
  • Sometime applying latest updates fix it.
  • Also make sure you login with farm admin account with local admin on the server.
  • Responses: 1. If you have installed the Anti-Vrius on the servers, try to to disable it - Need to check mostly not using anti virus 2. check if firewall is causing this issue. - Firewall is disabled 3. if you have any auditing or proctection software installed which may cause this issue. - Need to check mostly not using protection software 4. Try to run the psconfig -cmd upgrade -inplace b2b force on the all servers - Ran command multiple times on server, output of command always is "upgrade completed", the database status is no action required – Anna Jhaveri Apr 13 '17 at 15:17
  • 5. Sometime applying latest updates fix it. - Updates are installed last SharePoint update installed is KB3127940 6. Also make sure you login with farm admin account with local admin on the server. - I was logged in with install account which is a local admin on server @waqas – Anna Jhaveri Apr 13 '17 at 15:21
  • After monitoring ULS Logs i think the "service application instance provisioning job for service application" is becoming unresponsive and failing, so once that fails SharePoint tries to undo creating Service Application steps – Anna Jhaveri Apr 13 '17 at 15:34
  • Are all your servers saying no action required? Check from central admin...system settings > manage server in farm....also what are the min role for your Sharepoint servers – Waqas Sarwar MVP Apr 13 '17 at 15:43
  • Yes all servers saying no action required. I checked from central admin. > system settings > manage server in farm. We have 4 servers in farm 1. WFE with distributed cache server 2. Application server 3. Search server 4. Database server – Anna Jhaveri Apr 13 '17 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.