3

I am facing issues with a newly created SharePoint 2016 environment. The farm has 1 WFE, 1 app server, 1 search and 1 SQL server. All servers have 16-20 GB RAM. SharePoint 2016 install is complete and the product and config wizard has been run on all servers except the SQL server. Now I am at the step of creating service applications. The issues faced are:

  1. Service applications created through UI are taking a very long time to create(30 mins from UI and over 2 hours from powershell)
  2. The completion results in a ‘Request timeout error’ / and results in a partially created service application. Usually it doesn’t create the proxy and is the SA is stuck in starting state.
  3. Timeout occurs in the case of Deleting these applications as well hence I have to you the deleteconfiguration stsadm command to delete them and then delete the SA Database manually.
  4. one of the timer jobs 'UserProfileApplicationProxy - Unified Group Processing High Performance Job' keeps failing

Service applications that I have tried to create causing issues:

  1. Managed metadata service application
  2. BCS
  3. Usage and health data Collection Service application
  4. User profile service application
  5. Search service application

Resolutions tried: 1. IISRESET 2. Clearing timer job cache 3. Manually creating service applications and proxies using PowerShell and provisioning them. 4. Increasing shutdown time on the application pool for central admin in IIS 5. Installing updates(if any) and running products and config wizard again

I created a Web application and site collection and both of those got created in under 5 minutes.

Could anyone please tell me what may be the reason for the timeouts and why my service applications are breaking?

  • Ho Tosha did you solve your issue,can your user has proper permissions that performing above job to create service applicaions? – adilahmed Feb 25 '18 at 6:44
0

In this regards, we need to check the tcp port connectivity between your APP, WFE and SQL server. I have also faced the similar issue. By fixing the TCP connectivity in APP, WFE and SQL server the issue got fixed. For the scenario and solution you may refer the below - for you the scenario might the the different.

Similar type of issue:

https://global-sharepoint.com/2018/11/18/how-to-fix-request-timed-out-error-in-sharepoint-2016-search/

For SharePoint 2016 Port you may refer the below: https://blogit.create.pt/fabiocarvalho/2017/02/14/sharepoint-2016-tcpip-ports/

One more update:

I think in the SQL you have more than one server - and those belongs to sql availability group. Lets say "sqlserver-1" is a primary server and "sqlserver-2" is an secondary server, due to some reason may be due to networking issue, the primary server is not stable and at the same time the "sqlserver-2" is also not able to connect to the availability group and take the load.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.